Play on Words POJ - 1386

问题:

Some of the secret doors contain a very interesting word puzzle. The team of archaeologists has to solve it to open that doors. Because there is no other way to open the doors, the puzzle is very important for us. 

There is a large number of magnetic plates on every door. Every plate has one word written on it. The plates must be arranged into a sequence in such a way that every word begins with the same letter as the previous word ends. For example, the word ``acm'' can be followed by the word ``motorola''. Your task is to write a computer program that will read the list of words and determine whether it is possible to arrange all of the plates in a sequence (according to the given rule) and consequently to open the door. 

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer number Nthat indicates the number of plates (1 <= N <= 100000). Then exactly Nlines follow, each containing a single word. Each word contains at least two and at most 1000 lowercase characters, that means only letters 'a' through 'z' will appear in the word. The same word may appear several times in the list.

Output

Your program has to determine whether it is possible to arrange all the plates in a sequence such that the first letter of each word is equal to the last letter of the previous word. All the plates from the list must be used, each exactly once. The words mentioned several times must be used that number of times. 
If there exists such an ordering of plates, your program should print the sentence "Ordering is possible.". Otherwise, output the sentence "The door cannot be opened.". 

Sample Input

3
2
acm
ibm
3
acm
malform
mouse
2
ok
ok

Sample Output

The door cannot be opened.
Ordering is possible.
The door cannot be opened.

大意:

给你一堆由小写字母组成的字符串,你要把字符串按顺序排好,使后一个字符串的开头和前一个字符串的结尾相等,且要用上所有的字符串,如果能输出“Ordering is possible.”fo否则输出“The door cannot be opened.”。

思路:

1:这个题是让你判断是否是有向欧拉通路。

2:我们把每个字符串看成连接开头字符和结尾字符的一条通路,就可以利用欧拉通路的知识。

3:设有向欧拉通路D,则D满足:(1)D为连通图,(2)D的所有顶点出度等于入度 或 有两个点除外,其余顶点出度与入度相等,而且这两个顶点中一个顶点的出度与入度之差为1,另一个顶点出度与入度之差为-1.

代码:

#define N 1010
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
using namespace std;
int f[30],k[30],d[30];
int n;
int getf(int a)
{
    if(f[a]==a)return a;
    return f[a]=getf(f[a]);
}
void merge(int a,int b)
{
    int t1=getf(a);
    int t2=getf(b);
    if(t1!=t2)
        f[t2]=t1;
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        memset(k,0,sizeof(k));
        memset(d,0,sizeof(d));
        for(int i=0; i<30; i++)
            f[i]=i;
        char s[N];
        for(int i=0; i<n; i++)
        {
            scanf("%s",s);
            int l=strlen(s);
            k[s[0]-'a']++;//出度
            d[s[l-1]-'a']++;//入度
            merge(s[0]-'a',s[l-1]-'a');
        }
        int sum=0,flag=1;
        for(int i=0; i<26; i++)
        {
            if(k[i]!=d[i])
            {
                sum++;//
                if(abs(k[i]-d[i])!=1)//判断出度与入度差
                    flag=0;
            }
        }
        int c=0;
        for(int i=0; i<26; i++)
            if(k[i]||d[i])
            {
                if(f[i]==i)//判断图的连通性
                    c++;
            }
        if((sum==0||sum==2)&&flag&&c==1)
            printf("Ordering is possible.\n");
        else
            printf("The door cannot be opened.\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值