H - Play on Words POJ - 1386

Some of the secret doors contain a very interesting word puzzle. The team of archaeologists has to solve it to open that doors. Because there is no other way to open the doors, the puzzle is very important for us. 

There is a large number of magnetic plates on every door. Every plate has one word written on it. The plates must be arranged into a sequence in such a way that every word begins with the same letter as the previous word ends. For example, the word ``acm'' can be followed by the word ``motorola''. Your task is to write a computer program that will read the list of words and determine whether it is possible to arrange all of the plates in a sequence (according to the given rule) and consequently to open the door. 

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer number Nthat indicates the number of plates (1 <= N <= 100000). Then exactly Nlines follow, each containing a single word. Each word contains at least two and at most 1000 lowercase characters, that means only letters 'a' through 'z' will appear in the word. The same word may appear several times in the list.

Output

Your program has to determine whether it is possible to arrange all the plates in a sequence such that the first letter of each word is equal to the last letter of the previous word. All the plates from the list must be used, each exactly once. The words mentioned several times must be used that number of times. 
If there exists such an ordering of plates, your program should print the sentence "Ordering is possible.". Otherwise, output the sentence "The door cannot be opened.". 

Sample Input

3
2
acm
ibm
3
acm
malform
mouse
2
ok
ok

Sample Output

The door cannot be opened.
Ordering is possible.
The door cannot be opened.

题意:一扇门装了密码锁,给出一些单词,将这些单词首尾相连,连接的部分两个字母相同,即一个单词的最后一个字母和一个单词的第一个字母相同才能连在一起,这样,如果把这些单词都能够连接起来,那么就可以把门打开,问能否把门打开。

解法: 就是求欧拉回路,并且只有一条,联通分量为一,即判断首节点入度比出度小1,尾节点入度比出度大1,当然首尾也可以相等的

 

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<queue>
#include<vector>
using namespace std;
int in[30],out[30],vis[30],father[30];
int find(int a)
{
    if(a!=father[a])
        return father[a]=find(father[a]);
    return father[a];
}
int main()
{
    int t,n,i,m;
    char ch[1001];
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        memset(in,0,sizeof(in));
        memset(out,0,sizeof(out));
        memset(vis,0,sizeof(vis));
        for(i=1;i<=26;i++)
            father[i]=i;
        for(i=1;i<=n;i++)
        {
            scanf("%s",ch);
            m=strlen(ch);
            int x=ch[0]-'a'+1;
            int y=ch[m-1]-'a'+1;
            father[x]=father[y]=find(x);
            out[x]++;
            in[y]++;
            vis[x]=vis[y]=1;
        }
        int flag=0;
        for(i=1;i<=26;i++)
        {
            if(vis[i]==1&&father[i]==i)
                flag++;
        }
        if(flag>1)
        {
            printf("The door cannot be opened.\n");
            continue;
        }
        int a,b,c;
        a=0;
        b=0;
        c=0;
        for(i=1;i<=26;i++)
        {
            if(vis[i]==1&&out[i]!=in[i])
            {
                if(out[i]+1==in[i])
                    a++;
                else if(out[i]==in[i]+1)
                    b++;
                else
                    c++;
            }
        }
        if(c>0)
        {
            printf("The door cannot be opened.\n");
            continue;
        }
       if(a==1&&b==1)
        printf("Ordering is possible.\n");
       else if(a==0&&b==0)
        printf("Ordering is possible.\n");
       else
        printf("The door cannot be opened.\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值