Minimum Transport Cost HDU - 1385

问题

These are N cities in Spring country. Between each pair of cities there may be one transportation track or none. Now there is some cargo that should be delivered from one city to another. The transportation fee consists of two parts: 
The cost of the transportation on the path between these cities, and 

a certain tax which will be charged whenever any cargo passing through one city, except for the source and the destination cities. 

You must write a program to find the route which has the minimum cost. 

Input

First is N, number of cities. N = 0 indicates the end of input. 

The data of path cost, city tax, source and destination cities are given in the input, which is of the form: 

a11 a12 ... a1N 
a21 a22 ... a2N 
............... 
aN1 aN2 ... aNN 
b1 b2 ... bN 

c d 
e f 
... 
g h 

where aij is the transport cost from city i to city j, aij = -1 indicates there is no direct path between city i and city j. bi represents the tax of passing through city i. And the cargo is to be delivered from city c to city d, city e to city f, ..., and g = h = -1. You must output the sequence of cities passed by and the total cost which is of the form: 

Output

From c to d : 
Path: c-->c1-->......-->ck-->d 
Total cost : ...... 
...... 

From e to f : 
Path: e-->e1-->..........-->ek-->f 
Total cost : ...... 

Note: if there are more minimal paths, output the lexically smallest one. Print a blank line after each test case. 
 

Sample Input

5
0 3 22 -1 4
3 0 5 -1 -1
22 5 0 9 20
-1 -1 9 0 4
4 -1 20 4 0
5 17 8 3 1
1 3
3 5
2 4
-1 -1
0

Sample Output

From 1 to 3 :
Path: 1-->5-->4-->3
Total cost : 21

From 3 to 5 :
Path: 3-->4-->5
Total cost : 16

From 2 to 4 :
Path: 2-->1-->5-->4
Total cost : 17

题意:

给你一个邻接矩阵,k[i][j]表示从 i 城道 j 城所需要的花费,下一行是如果从这个城市路过(不是起始城市,也不是终点城市)需要另外交的费用,后面若干行给你起点城市和终点城市,问你需要的最少花费,把路径输出来,如果有多条,输出字典序最小的。然后输出最小花费,无法到达输出-1

思路:

数据比较小可以直接用Floyd-Warshall算法,用dis[ i ][ j ]数组保留路径,dis[ i ][ j ]=h表示从 i 到 j 是 i 先到 h 再到 j 的。

代码:

#define N 1010
#define inf 0x3f3f3f3f
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
int k[N][N],p[N];
int n,dis[N][N];//dis数组记录是从那个城市到这个城市的
int main()
{
    while(scanf("%d",&n)&&n)
    {
        memset(dis,0,sizeof(dis));
        for(int i=1; i<=n; i++)
            for(int j=1; j<=n; j++)
            {
                dis[i][j]=j;//未更新时是i直接到j
                scanf("%d",&k[i][j]);
                if(k[i][j]==-1)
                    k[i][j]=inf;
            }
        for(int i=1; i<=n; i++)
            scanf("%d",&p[i]);
        for(int h=1; h<=n; h++)
            for(int i=1; i<=n; i++)
            {
                for(int j=1; j<=n; j++)
                {
                    if(k[i][j]>k[i][h]+p[h]+k[h][j])
                    {
                        k[i][j]=k[i][h]+p[h]+k[h][j];
                        dis[i][j]=dis[i][h];//意思为i到j是i先到h再到j
                    }
                    if(k[i][j]==k[i][h]+p[h]+k[h][j])//按字典序最小
                    {
                        dis[i][j]=min(dis[i][j],dis[i][h]);
                    }
                }
            }
        int a,b;
        while(scanf("%d%d",&a,&b))
        {
            if(a==-1&&b==-1)break;

            int c=a,e=b;
            int d[N],l=0;
            int s=k[a][b];
            while(a!=b)//把路径提取出来
            {
                d[l++]=dis[a][b];
                a=dis[a][b];
            }
            printf("From %d to %d :\n",c,e);
            printf("Path: %d",c);
            for(int i=0; i<l; i++)
                printf("-->%d",d[i]);
            printf("\n");
            if(k[c][e]<inf)
                printf("Total cost : %d\n",k[c][e]);
            else
                printf("-1\n");
            printf("\n");
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值