水题。。Floyd求最短路,开个path数组记录路径就好了。。
Total Submission(s): 6019 Accepted Submission(s): 1520
Minimum Transport Cost
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 6019 Accepted Submission(s): 1520
Problem Description
These are N cities in Spring country. Between each pair of cities there may be one transportation track or none. Now there is some cargo that should be delivered from one city to another. The transportation fee consists of two parts:
The cost of the transportation on the path between these cities, and
a certain tax which will be charged whenever any cargo passing through one city, except for the source and the destination cities.
You must write a program to find the route which has the minimum cost.
The cost of the transportation on the path between these cities, and
a certain tax which will be charged whenever any cargo passing through one city, except for the source and the destination cities.
You must write a program to find the route which has the minimum cost.
Input
First is N, number of cities. N = 0 indicates the end of input.
The data of path cost, city tax, source and destination cities are given in the input, which is of the form:
a11 a12 ... a1N
a21 a22 ... a2N
...............
aN1 aN2 ... aNN
b1 b2 ... bN
c d
e f
...
g h
where aij is the transport cost from city i to city j, aij = -1 indicates there is no direct path between city i and city j. bi represents the tax of passing through city i. And the cargo is to be delivered from city c to city d, city e to city f, ..., and g = h = -1. You must output the sequence of cities passed by and the total cost which is of the form:
The data of path cost, city tax, source and destination cities are given in the input, which is of the form:
a11 a12 ... a1N
a21 a22 ... a2N
...............
aN1 aN2 ... aNN
b1 b2 ... bN
c d
e f
...
g h
where aij is the transport cost from city i to city j, aij = -1 indicates there is no direct path between city i and city j. bi represents the tax of passing through city i. And the cargo is to be delivered from city c to city d, city e to city f, ..., and g = h = -1. You must output the sequence of cities passed by and the total cost which is of the form:
Output
From c to d :
Path: c-->c1-->......-->ck-->d
Total cost : ......
......
From e to f :
Path: e-->e1-->..........-->ek-->f
Total cost : ......
Note: if there are more minimal paths, output the lexically smallest one. Print a blank line after each test case.
Path: c-->c1-->......-->ck-->d
Total cost : ......
......
From e to f :
Path: e-->e1-->..........-->ek-->f
Total cost : ......
Note: if there are more minimal paths, output the lexically smallest one. Print a blank line after each test case.
Sample Input
5
0 3 22 -1 4
3 0 5 -1 -1
22 5 0 9 20
-1 -1 9 0 4
4 -1 20 4 0
5 17 8 3 1
1 3
3 5
2 4
-1 -10
0 3 22 -1 4
3 0 5 -1 -1
22 5 0 9 20
-1 -1 9 0 4
4 -1 20 4 0
5 17 8 3 1
1 3
3 5
2 4
-1 -10
Sample Output
From 1 to 3 :
Path: 1-->5-->4-->3
Total cost : 21
From 3 to 5 :
Path: 3-->4-->5
Total cost : 16
From 2 to 4 :
Path: 2-->1-->5-->4
Total cost : 17
#include <iostream>
#include <cstdlib>
#include <cstdio>
#include <cstring>
using namespace std;
#define A system("pause")
#define INF 1<<29
const int maxn=110;
int n;
int map[maxn][maxn],path[maxn][maxn],tax[maxn];
void make_map()
{
int i,j;
for(i=1;i<=n;i++)
{
for(j=1;j<=n;j++)
{
cin>>map[i][j];
if(map[i][j]==-1)
map[i][j]=INF;
}
}
}
void Floyd()
{
int i,j,k;
for(i=1;i<=n;i++)
{
for(j=1;j<=n;j++)
{
path[i][j]=j;
}
}
for(k=1;k<=n;k++)
{
for(i=1;i<=n;i++)
{
for(j=1;j<=n;j++)
{
if(map[i][k]+map[k][j]+tax[k]<map[i][j])
{
map[i][j]=map[i][k]+map[k][j]+tax[k];
path[i][j]=path[i][k];
}
else if(map[i][j]==map[i][k]+map[k][j]+tax[k])
{
path[i][j]=min(path[i][j],path[i][k]);
}
}
}
}
}
void Print_path(int s,int e)
{
int i,j,cur;
printf("From %d to %d :\n",s,e);
printf("Path: %d",s);
//printf("这程序真烂!\n\n");
//A;
cur=s;
while(cur!=e)
{
printf("-->%d",path[cur][e]);
//printf("这程序真烂aaaaaaaaaaaaaaaaaaaaaa!\n\n");
cur=path[cur][e];
}
printf("\n");
printf("Total cost : %d\n\n",map[s][e]);
}
int main()
{
int i,j,s,e;
while(cin>>n&&n)
{
make_map();
for(i=1;i<=n;i++)
cin>>tax[i];
Floyd();
while(cin>>s>>e)
{
if(s==-1&&e==-1)
break;
//printf("这程序真烂!\n\n");
Print_path(s,e);
}
}
return 0;
}