hdu-1385 Minimum Transport Cost(Dijkstra最短路径算法)

Minimum Transport Cost
Time Limit:2000MS     Memory Limit:65536KB
Description
These are N cities in Spring country. Between each pair of cities there may be one transportation track or none. Now there is some cargo that should be delivered from one city to another. The transportation fee consists of two parts:
The cost of the transportation on the path between these cities, and

a certain tax which will be charged whenever any cargo passing through one city, except for the source and the destination cities.

You must write a program to find the route which has the minimum cost.

Input

First is N, number of cities. N = 0 indicates the end of input.

The data of path cost, city tax, source and destination cities are given in the input, which is of the form:

a11 a12 ... a1N
a21 a22 ... a2N
...............
aN1 aN2 ... aNN
b1  b2  ... bN

c d
e f
...
g h

where aij is the transport cost from city i to city j, aij = -1 indicates there is no direct path between city i and city j. bi represents the tax of passing through city i. And the cargo is to be delivered from city c to city d, city e to city f, ..., and g = h = -1. You must output the sequence of cities passed by and the total cost which is of the form:

Output

From c to d :
Path: c-->c1-->......-->ck-->d
Total cost : ......
......

From e to f :
Path: e-->e1-->..........-->ek-->f
Total cost : ......

Note: if there are more minimal paths, output the lexically smallest one. Print a blank line after each test case.

Sample Input

5
0 3 22 -1 4
3 0 5 -1 -1
22 5 0 9 20
-1 -1 9 0 4
4 -1 20 4 0
5 17 8 3 1
1 3
3 5
2 4
-1 -1
0

Sample Output

From 1 to 3 :
Path: 1-->5-->4-->3
Total cost : 21

From 3 to 5 :
Path: 3-->4-->5
Total cost : 16

From 2 to 4 :
Path: 2-->1-->5-->4

Total cost : 17

Dijkstra算法详解:http://blog.sina.com.cn/s/blog_4b9aefc20100zu8h.html

/*
求在n个城市中从s城市到e城市的最小花费。
i到j的花费由j城市的税和该路的花费组成,起点终点不算税。
该题注意:1测试数据中有i->i的情况;2相同花费的路径按字典顺序小的优先输出;
*/
#include<iostream>
#include<stdio.h>
#include<vector>
#include<string>
#include<algorithm>
#include<string.h>
using namespace std;
#define maxl 100
int tax[maxl],map[maxl][maxl];//tax保存税费,map保存输入的路费
int cost[maxl][maxl];//从i到j的总花费
int pre[maxl];//保存到达该城市的上一个城市
int dist[maxl];//用于dijkstra算法中保存i与已到达城市的最短距离
int f[maxl][maxl];//邻接表储存与i直接相通的城市
void output(int s,int e,int &sum)//因为pre[i]中保存的是上个一城市,
{                                //所以要从终点找到起点,从起点开始输出路径
	if(s==e){
		printf("Path: %d",s);
		return;
	}
	sum+=cost[pre[e]][e];
	output(s,pre[e],sum);
	printf("-->%d",e);
}
bool cmp(const int &a,const int &b)
{
	return dist[a]<dist[b];
}
int main()
{
	int i,j,m,n,s,e;
	while(scanf("%d",&n)&&n)
	{
		for(i=1;i<=n;i++)
			for(j=1;j<=n;j++)
				scanf("%d",&map[i][j]);
			for(i=1;i<=n;i++)
				scanf("%d",&tax[i]);
			while(scanf("%d%d",&s,&e))
			{
				if(s==-1&&e==-1) break;
				for(i=1;i<=n;i++)
				{
					f[i][0]=0;
					for(j=1;j<=n;j++)
					{
						if(i==j) continue;
						if(map[i][j]==-1) cost[i][j]=0x3f3f3f3f;
						else {
							cost[i][j]=map[i][j]+tax[j];
							f[i][++f[i][0]]=j;
						}
					}
				}
					vector<int> vec;//保存尚未到达的城市
					for(i=1;i<=n;i++)
					{
						if(i==s) dist[i]=0;
						else {
							dist[i]=cost[s][i];
							vec.push_back(i);
						}
						pre[i]=s;
					}
					sort(vec.begin(),vec.end(),cmp);
					while(!vec.empty())
					{
						int k=vec[0];
						vec.erase(vec.begin());
						for(i=1;i<=f[k][0];i++)
						{
							int z=f[k][i];
							if((dist[k]+cost[k][z])<dist[z]){//Dijkstra算法
								dist[z]=dist[k]+cost[k][z];
								pre[z]=k;
							}
							else if((dist[k]+cost[k][z])==dist[z])//花费相同路径,找出这两条路径进行比较
							{
								int kk=k,zz=pre[z];
								string a,b;
								a+=char(z+'0');
								b+=char(z+'0');
								while(kk!=s) a=char(kk+'0')+a,kk=pre[kk];
								while(zz!=s) b=char(zz+'0')+b,zz=pre[zz];
								if(a<b){
									dist[z]=dist[k]+cost[k][z];
									pre[z]=k;
								}
							}
						}
						sort(vec.begin(),vec.end(),cmp);
					}
					int w=s,sum=0;
					printf("From %d to %d :\n",s,e);
					output(s,e,sum);
					if(s!=e) sum-=tax[e];//i->i输出0
					printf("\n");
					printf("Total cost : %d\n\n",sum);
			}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值