hdu1385Minimum Transport Cost(最短路变种)

题目链接:

思路:

输出路径的最短路变种问题。。这个题目在于多组询问,那么个人觉得用floyd更加稳妥一点。还有就是在每个城市都有过路费,所以在floyd的时候更改一下松弛条件即可。。那么输出路径怎么办呢??我采用的是输出起点的后继而不是终点的前驱。。因为我们关心的是路径字典序最小,关心的是起点的后继。。。那么打印路径的时候就直接从前向后打印,这个和dijkstra的打印路径稍有不同。。。最短路的打印参见传送门
题目:

Minimum Transport Cost

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7538    Accepted Submission(s): 1935


Problem Description
These are N cities in Spring country. Between each pair of cities there may be one transportation track or none. Now there is some cargo that should be delivered from one city to another. The transportation fee consists of two parts: 
The cost of the transportation on the path between these cities, and

a certain tax which will be charged whenever any cargo passing through one city, except for the source and the destination cities.

You must write a program to find the route which has the minimum cost.
 

Input
First is N, number of cities. N = 0 indicates the end of input.

The data of path cost, city tax, source and destination cities are given in the input, which is of the form:

a11 a12 ... a1N
a21 a22 ... a2N
...............
aN1 aN2 ... aNN
b1 b2 ... bN

c d
e f
...
g h

where aij is the transport cost from city i to city j, aij = -1 indicates there is no direct path between city i and city j. bi represents the tax of passing through city i. And the cargo is to be delivered from city c to city d, city e to city f, ..., and g = h = -1. You must output the sequence of cities passed by and the total cost which is of the form:
 

Output
From c to d :
Path: c-->c1-->......-->ck-->d
Total cost : ......
......

From e to f :
Path: e-->e1-->..........-->ek-->f
Total cost : ......

Note: if there are more minimal paths, output the lexically smallest one. Print a blank line after each test case.

 

Sample Input
   
   
5 0 3 22 -1 4 3 0 5 -1 -1 22 5 0 9 20 -1 -1 9 0 4 4 -1 20 4 0 5 17 8 3 1 1 3 3 5 2 4 -1 -1 0
 

Sample Output
   
   
From 1 to 3 : Path: 1-->5-->4-->3 Total cost : 21 From 3 to 5 : Path: 3-->4-->5 Total cost : 16 From 2 to 4 : Path: 2-->1-->5-->4 Total cost : 17
 

Source
 

Recommend
Eddy   |   We have carefully selected several similar problems for you:   1142  1217  2112  2722  1598 


代码:
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
#define INF 0x3f3f3f3f
using namespace std;

const int maxn=50+10;
int dis[maxn][maxn],path[maxn][maxn],n,cost[maxn];
int u,st,en;

void floyd()
{
    for(int k=1;k<=n;k++)
      for(int i=1;i<=n;i++)
        for(int j=1;j<=n;j++)
    {
        int tmp=dis[i][k]+dis[k][j]+cost[k];
        if(tmp<dis[i][j]||(tmp==dis[i][j]&&path[i][j]>path[i][k]))
        {
            dis[i][j]=tmp;
            path[i][j]=path[i][k];
        }
    }
}

void read_Graph()
{
    for(int i=1;i<=n;i++)
        for(int j=1;j<=n;j++)
    {
        scanf("%d",&u);
        if(u==-1)
            dis[i][j]=INF;
        else
        {
            dis[i][j]=u;
            path[i][j]=j;
        }
    }
    for(int i=1;i<=n;i++)
       scanf("%d",&cost[i]);
}

void solve()
{
    while(~scanf("%d%d",&st,&en))
    {
        if(st==-1&&en==-1)  break;
        printf("From %d to %d :\n",st,en);
        printf("Path: %d",st);
        int Gery=st;
        while(Gery!=en)
        {
            printf("-->%d",path[Gery][en]);
            Gery=path[Gery][en];
        }
        printf("\nTotal cost : %d\n\n",dis[st][en]);
    }
}

int main()
{
    while(~scanf("%d",&n),n)
    {
        read_Graph();
        floyd();
        solve();
    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值