Anniversary party POJ - 2342

问题:

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.

Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go N – 1 lines that describe a supervisor relation tree. Each line of the tree specification has the form: 
L K 
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line 
0 0 

Output

Output should contain the maximal sum of guests' ratings.

Sample Input

7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0

Sample Output

5

题意:

n个人要来学校聚会,然后n行,按1~n行每行表示第几个人来参加聚会的能获得的欢乐值,下面若干行表示(a,b)表示a是b的直接上司,聚会为了防止尴尬b和b的直接上司不能同时参加聚会,问欢乐值的总和最多为多少。

思路:

树形dp算法,dp[ i ][ 0 ] i 不参加聚会能获得的最多欢乐值,dp[ i ][ 1 ]表示 i 参加聚会能获得的最多欢乐值。

代码:

#define N 6010
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int f[N],book[N],n;
int dp[N][2],k[N];
void dfs(int a)
{
    book[a]=1;
    for(int i=1; i<=n; i++)
    {
        if(!book[i]&&f[i]==a)
        {
            dfs(i);
            dp[a][0]+=max(dp[i][0],dp[i][1]);//如果a不参加,他的直接上司可以参加,也可以不参加
            dp[a][1]+=dp[i][0];//如果a参加,他的上司就不能参加
        }
    }
}
int main()
{
    while(~scanf("%d",&n))
    {
        memset(book,0,sizeof(book));
        memset(k,0,sizeof(k));
        for(int i=1; i<=n; i++)
        {
            scanf("%d",&dp[i][1]);
            dp[i][0]=0;
        }
        int a,b;
        while(scanf("%d%d",&a,&b)&&(a||b))
        {
            f[a]=b;//a是b的直接上司
            k[a]=1;
        }
        for(int i=1; i<=n; i++)
            if(!k[i])a=i;
        dfs(a);
        printf("%d\n",max(dp[a][0],dp[a][1]));
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值