poj2342 Anniversary party(树形dp)

Anniversary party
Time Limit: 1000MS
Memory Limit: 65536K
Total Submissions: 5516
Accepted: 3164

Description

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.

Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go N – 1 lines that describe a supervisor relation tree. Each line of the tree specification has the form: 
L K 
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line 
0 0 

Output

Output should contain the maximal sum of guests' ratings.

Sample Input

7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0

Sample Output

5

Source


题意:某公司要举办一次晚会,但是为了使得晚会的气氛更加活跃,每个参加晚会的人都不希望在晚会中见到他的直接上司,现在已知每个人的活跃指数和上司关系(当然不可能存在环),求邀请哪些人(多少人)来能使得晚会的总活跃指数最大。
分析:已每个员工之间的关系建立一颗关系树;任何一个点的取舍可以看做一种决策,对于每个点以它为根的子树活跃度最大。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <cmath>
#include <algorithm>
using namespace std;
const double eps = 1e-6;
const double pi = acos(-1.0);
const int INF = 0x3f3f3f3f;
const int MOD = 1000000007;
#define ll long long
#define CL(a,b) memset(a,b,sizeof(a))

int n;
int dp[6005][2],father[6005];//dp[i][0]表示i不去,dp[i][1]表示i去
bool vis[6005];

void tree_dp(int node)
{
    vis[node] = true;
    for(int i=1; i<=n; i++)
    {
        if(!vis[i]&&father[i]==node)//i为node的孩子
        {
            tree_dp(i);
            dp[node][1] += dp[i][0];//上司来
            dp[node][0] += max(dp[i][0], dp[i][1]);//上司不来,下属来or不来
        }
    }
}

int main()
{
    int f,c,root;
    while(scanf("%d",&n)==1)
    {
        CL(dp, 0);
        CL(father, 0);
        CL(vis, false);
        for(int i=1; i<=n; i++)
            scanf("%d",&dp[i][1]);
        root = 0;//记录父亲结点
        while(scanf("%d%d",&c,&f),c||f)//建树
        {
            father[c] = f;
            root=f;
        }
        while(father[root])//查找父结点
            root = father[root];
        tree_dp(root);
        printf("%d\n",max(dp[root][0], dp[root][1]));
    }
    return 0;
}


总结:第一次写树形dp,以前总感觉只要和树扯上关系的就很麻烦,一直没去了解树形dp,今天想尝试一下,发现其实也没有想象中的那么麻烦,也就是用题目给出的关系建立一颗关系树,然后以每个结点为根结点求出题目的所有解,最后挑一个最合适的就好了,虽然这只是一道最基础的入门题,但是我觉得应该也都差不多吧,可能有些树会比较难建吧,应该还好。
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值