Harmonic Number (II) LightOJ - 1245

问题:

I was trying to solve problem '1234 - Harmonic Number', I wrote the following code

long long H( int n ) {
    long long res = 0;
    for( int i = 1; i <= n; i++ )
        res = res + n / i;
    return res;
}

Yes, my error was that I was using the integer divisions only. However, you are given n, you have to find H(n) as in my code.

Input

Input starts with an integer T (≤ 1000), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n < 231).

Output

For each case, print the case number and H(n) calculated by the code.

Sample Input

11

1

2

3

4

5

6

7

8

9

10

2147483647

Sample Output

Case 1: 1

Case 2: 3

Case 3: 5

Case 4: 8

Case 5: 10

Case 6: 14

Case 7: 16

Case 8: 20

Case 9: 23

Case 10: 27

Case 11: 46475828386

题意:

输入一个n,然后让你输出上述代码所输出的结果。

思路:

如果直接运行上面的代码肯定会超时,这个题我刚开始是先输出前面十几项,然后找规律,最后又想想知道了原因,因为n/i得到的是个整数,假设a=n/bi,n正好能被bi整除,a-1=n/ci也是正好能整除,那么当i=ci~bi-1范围内时 n/i 就等于a-1.

代码:

#define N 10000
#include<math.h>
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int main()
{
    long long n,T,Case=1;
    scanf("%lld",&T);
    while(T--)
    {
        scanf("%lld",&n);
        long long sum=0;
        for(long long int i=1; i<=n; i++)
        {
            sum+=n/i;
            long long a;
            a=n/i;a=n/a;//跳过ci~bi-1之间存在余数的范围
            if(a<i)break;
            sum+=(a-i)*(n/i);//(a-i)就是(ci~bi-1之间的个数)
            i=a;
        }
        printf("Case %lld: %lld\n",Case++,sum);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值