ZOJ Problem Set - 1016

【【模拟题】】


题目


Parencodings


Time Limit: 1 Second     Memory Limit:32768 KB


Let S = s1 s2 ... s2n be a well-formed string of parentheses. S can be encoded in two different ways:

  • By an integer sequence P = p1 p2 ... pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence).
  • By an integer sequence W = w1 w2 ... wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence).

Following is an example of the above encodings:

S (((()()())))
P-sequence 4 5 6666
W-sequence 1 1 1456

Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string.


Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.


Output

The output consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.


Sample Input

2
6
4 5 6 6 6 6
9
4 6 6 6 6 8 9 9 9


Sample Output

1 1 1 4 5 6
1 1 2 4 5 1 1 3 9


Source: Asia 2001, Tehran (Iran)

题意说明

      设S序列 S =s1 s2...s2n 为由“(”和“)”组成的字符串,其中左括号和右括号完全匹配。S序列可以按照两种方式编码:一种是编为P = p1p2 ... pn的整数序列,序列中pi被定义为S序列中第i个右括号前面的左括号数;一种是编为W = w1w2 ... wn的整数序列,序列中wi被定义为S序列中第i个右括号和与其匹配的左括号之间所包含的所有正确匹配的括号对数目(包括该第i个右括号与其匹配的左括号组成的这一对)。要求输入P序列,输出W序列。

解答

(一)分析:先由P序列还原出S序列,再由S序列得到W序列。由于S序列是括号完全匹配的,所以2个对应的左右括号之间包含的也是匹配好的括号对集,所以得wi=[(ri-li)/2]+1,(ri为第i个右括号在S序列中的下标,li为其对应的左括号在S序列中的下标)。

(二)代码

#include<iostream>
#include<stack>
using namespace std;
int main()
{
	char s[41];
	int p;
	int t,n,i,j,k,m,pm,len,left,w;
	stack<int> st;
	cin>>t;
	for(i=0;i<t;i++)
	{
		cin>>n;
		m=0;
		pm=0;
		for(j=0;j<n;j++)
		{
            cin>>p;//逐个输入P序列的数项
			pm=p-pm;//得到第j个右括号和第j-1个右括号之间的左括号数pm
			//还原字符串S序列
			for(k=0;k<pm;k++)
			{
				s[m++]='(';
			}
			s[m]=')';
			m++;
			pm=p;
		}
		s[m]='\0';
		len=2*n;
		//由S序列得到W序列
		for(j=0;j<len;j++)
		{
			if(s[j]=='(')
				st.push(j);
			else{//遇右括号逐个输出W序列的数项
               left=st.top();
			   w=(j-left)/2+1;
			   st.pop();
			   if(j!=len-1)
				   cout<<w<<' ';
			   else
				   cout<<w<<endl;
			}
		}
	}
        return 0;
}
//Accepted

 

(解于2009/10)

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值