hdu6098--Inversion

Problem Description

Give an array A, the index starts from 1.
Now we want to know Bi=maxijAj , i2 .

Input

The first line of the input gives the number of test cases T; T test cases follow.
Each case begins with one line with one integer n : the size of array A.
Next one line contains n integers, separated by space, ith number is Ai .

Limits
T20
2n100000
1Ai1000000000
n700000

Output

For each test case output one line contains n-1 integers, separated by space, ith number is Bi+1 .
 

Sample Input

  
  
2 4 1 2 3 4 4 1 4 2 3

Sample Output

  
  
3 4 3 2 4 4
 

题意

已知序列Ai,求序列Bi,使得Bi = max Aj,并且i%j != 0

分析

可以将序号和取值放到结构体中,按照数值从大到小排序

从头遍历,保证Bi%j!=0的第一个数一定是最大的Bj

代码


#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;
struct A{
    int a,num;
}e[100000+10];
bool cmp(A a,A b)
{
    return a.a>b.a;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
        {
            int x;
            scanf("%d",&x);
            e[i].a=x;
            e[i].num=i;
        }
        sort(e+1,e+n+1,cmp);
        for(int i=2;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                if(e[j].num%i!=0)
                {
                    if(i!=2)
                        cout<<" ";
                    cout<<e[j].a;
                    break;
                }
            }
        }
        cout<<endl;
    }
    return 0;
}

链接

http://acm.hdu.edu.cn/showproblem.php?pid=6098

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值