HDU 6106 Classes【简单思维】

题目来戳呀

Problem Description

The school set up three elective courses, assuming that these courses are A, B, C. N classes of students enrolled in these courses.
Now the school wants to count the number of students who enrolled in at least one course in each class and records the maximum number of students.
Each class uploaded 7 data, the number of students enrolled in course A in the class, the number of students enrolled in course B, the number of students enrolled in course C, the number of students enrolled in course AB, the number of students enrolled in course BC, the number of students enrolled in course AC, the number of students enrolled in course ABC. The school can calculate the number of students in this class based on these 7 data.
However, due to statistical errors, some data are wrong and these data should be ignored.
Smart you must know how to write a program to find the maximum number of students.

Input

The first line of the input gives the number of test cases T; T test cases follow.
Each case begins with one line with one integer N, indicates the number of class.
Then N lines follow, each line contains 7 data: a, b, c, d, e, f, g, indicates the number of students enrolled in A, B, C, AB, BC, AC, ABC in this class.
It’s guaranteed that at least one data is right in each test case.

Limits
T≤100
1≤N≤100
0≤a,b,c,d,e,f,g≤100

Output

For each test case output one line contains one integer denotes the max number of students who enrolled in at least one course among N classes.

Sample Input

2
2
4 5 4 4 3 2 2
5 3 1 2 0 0 0
2
0 4 10 2 3 4 9
6 12 6 3 5 3 2

Sample Output

7
15

Hint

In the second test case, the data uploaded by Class 1 is wrong.
Because we can’t find a solution which satisfies the limitation.
As for Class 2, we can calculate the number of students who only enrolled in course A is 2,
the number of students who only enrolled in course B is 6, and nobody enrolled in course C,
the number of students who only enrolled in courses A and B is 1,
the number of students who only enrolled in courses B and C is 3,
the number of students who only enrolled in courses A and C is 1,
the number of students who enrolled in all courses is 2,
so the total number in Class 2 is 2 + 6 + 0 + 1 + 3 + 1 + 2 = 15.

Source

2017 Multi-University Training Contest - Team 6

题意:

给你n个班级,A,B,C三门课,每个班级下给你7个数据,分别表示上A,B,C,AB,BC,AC,ABC 7种课程的人数。求出这些班级中上的课程门数≥1的人数中最多的。但是给的7个数据不完全正确。

想法:

由给出的样例解释,我们易发现 题目给出的7个数据中
A中包含只参加A的,同时参加AB的,AC的,ABC的
同理AB中包含 同时参加AB的 ABC的
我们发现 只有ABC就是ABC本身
所以ABC的值为突破口,逆推回去,就能依次找到每种课程的人数了。

唯一的思考点就在理解为什么说有的数据可能不对的情况了+_+

#include<bits/stdc++.h>
using namespace std;
int main()
{
    int t,n,k,ans[110],a[110];
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        memset(ans,0,sizeof ans);
        for( k=1; k<=n; ++k)
        {
            memset(a,0,sizeof a);
            for(int i=1; i<=7; ++i)
                scanf("%d",&a[i]);
            a[6]=a[6]-a[7];
            a[5]=a[5]-a[7];
            a[4]=a[4]-a[7];
            a[3]=a[3]-a[5]-a[6]-a[7];
            a[2]=a[2]-a[4]-a[5]-a[7];
            a[1]=a[1]-a[4]-a[6]-a[7];
            for(int i=1; i<=7; ++i)
            {
                if(a[i]<0)
                {
                    ans[k]=0;///注意这里不符合时要清零 否则会计算到下面的ans中
                    break;
                }
                else
                   ans[k]+=a[i];
            }
        }
        sort(ans+1,ans+n+1);
        printf("%d\n",ans[n]);
    }
    return 0;
}

ps:刚开始以为前后数据意义一样+_+

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值