PAT甲级练习题-Waiting in Line (30)-队列模拟

1014. Waiting in Line (30)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are:

  • The space inside the yellow line in front of each window is enough to contain a line with M customers. Hence when all the N lines are full, all the customers after (and including) the (NM+1)st one will have to wait in a line behind the yellow line.
  • Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number.
  • Customer[i] will take T[i] minutes to have his/her transaction processed.
  • The first N customers are assumed to be served at 8:00am.

Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.

For example, suppose that a bank has 2 windows and each window may have 2 customers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At 08:00 in the morning, customer1 is served at window1 while customer2 is served at window2. Customer3 will wait in front of window1 and customer4 will wait in front of window2. Customer5 will wait behind the yellow line.

At 08:01, customer1 is done and customer5 enters the line in front of window1 since that line seems shorter now. Customer2 will leave at 08:02, customer4 at 08:06, customer3 at 08:07, and finally customer5 at 08:10.

Input

Each input file contains one test case. Each case starts with a line containing 4 positive integers: N (<=20, number of windows), M (<=10, the maximum capacity of each line inside the yellow line), K (<=1000, number of customers), and Q (<=1000, number of customer queries).

The next line contains K positive integers, which are the processing time of the K customers.

The last line contains Q positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to K.

Output

For each of the Q customers, print in one line the time at which his/her transaction is finished, in the format HH:MM where HH is in [08, 17] and MM is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output "Sorry" instead.

Sample Input
2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7
Sample Output
08:07
08:06
08:10
17:00
Sorry



/**
题意:
n个窗口,黄线内最多排队m人,k个人依次来,q个问题
来的人会自动选择人少小号窗口开始进队,直到黄线内人满了,
等有人办理完业务然后再选择人少,号小的队伍入队,
银行8点开门,开始办理业务的时间晚于17点则不服务,输出Sorry
输出q个人的办理时间

题解:
模拟,用时间轴,表示当前时间,记录每队办理完业务距离当前时间的时间差
从小编号开始选取最小的(即最早完成业务的),记录此人完成业务的时间,
将当前时间更改为完成业务的时间,并且更新其余队列的时间差。
*/

#include <cstdio>
#include <cassert>
#include <iostream>
#include <queue>
#include <algorithm>

using namespace std;

const int INF = 0x3f3f3f3f;
const int maxn = 1000 + 5;

queue<int> que[25];///窗口
int w[25];///每个窗口与当前的时间差
int f[maxn];///每个人的完成时间
int a[maxn];///每个人的处理时间
int main() {
    int n,m,k,q;
    scanf("%d%d%d%d",&n,&m,&k,&q);
    for(int i = 0;i<k;++i)
        scanf("%d",&a[i]);
    int id = 0;
    for(int i = 0;i<m;++i){
        for(int j = 0;j<n;++j){
            que[j].push(id++);
            if(id >=k) break;
        }
    }
    for(int i = 0;i<n;++i){
        if(!que[i].empty()){
            w[i] = a[que[i].front()];
        }
    }
    int cur = 0;///当前时间
    while(1){
        int mint = INF,minn = -1;
        ///找到最早完成业务的窗口
        for(int i = 0;i<n;++i){
            if(!que[i].empty() && mint>w[i]){
                mint = w[i];
                minn = i;
            }
        }
        if(minn == -1) break;
        cur  += mint;///更新当前时间
        f[que[minn].front()] = cur;///更新结束时间
        que[minn].pop();
        ///进入下一个人
        if(id<k){
            que[minn].push(id++);
        }
        ///更新当前队列信息
        if(!que[minn].empty())
            w[minn] = a[que[minn].front()];

        for(int i = 0;i<n;++i){
            if(que[i].empty() || i ==minn) continue;
            w[i] -= mint;
        }
    }
    for(int i = 0;i<q;++i){
        int x;
        scanf("%d",&x);
        x--;
        if(f[x]-a[x] >= 540)///开始时间晚于17点
            printf("Sorry\n");
        else
            printf("%02d:%02d\n",f[x]/60 +8 ,f[x]%60);
    }

    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值