1002. A+B for Polynomials (25)
This time, you are supposed to find A+B where A and B are two polynomials.
Input
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.
Output
For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.
Sample Input2 1 2.4 0 3.2 2 2 1.5 1 0.5Sample Output
3 2 1.5 1 2.9 0 3.2
/**
题意:多项式a+b求解,结果保留一位小数,输出时按指数递减输出,
*/
#include<bits/stdc++.h>
using namespace std;
typedef pair<int,int> P;
const int maxn = 1000+10;
const int INF = 0x3f3f3f3f;
double a[maxn],b[maxn];
int main(){
int k,t;
scanf("%d",&k);
for(int i = 0;i<k;++i){
scanf("%d",&t);
scanf("%lf",&a[t]);
}
scanf("%d",&k);
for(int i = 0;i<k;++i){
scanf("%d",&t);
scanf("%lf",&b[t]);
}
vector<int> ans;
for(int i = maxn;i>=0;--i){
b[i] = a[i]+b[i];
if(b[i]==0) continue;
ans.push_back(i);
}
cout<<ans.size();
for(int i = 0;i<ans.size();++i){
printf(" %d %.1f",ans[i],b[ans[i]]);
}
return 0;
}