PAT真题练习(甲级)——1001A+B Format

1001 A+B Format

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −106≤a,b≤106. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

自己写的:zh


#include <stdio.h>
#include <stdlib.h>
int main(){
	int a,b;
    printf("请输入a和b的值"); 
	scanf("%d,%d",&a,&b);
	int c;
	c=a+b;
	if(c==0)
	  printf("%d\n",c);
	else if(c>0){
	  int n=c; 
	  while((n/10)<10){
	  	int count;
		count++;
	  	if(count==3)
	  	   printf("%d",n);
	  	else printf(",%d",n);
	  }
    }
    else{
    	int flag;
    	flag=-1;
    	int n=flag*c;
    	while((n/10)<10){
	  	int count;
		count++;
	  	if(count==3)
	  	   printf("%d",n*flag);
	  	else printf(",%d",n*flag);
	  }
    	
	}
	return 0;
	
}

 


人家写的:

#include <iostream>
using namespace std;
int main() {
    int a, b;
    cin >> a >> b; //输入a和b
    string s = to_string(a + b); //将a+b的值转换为字符串
    if(s[0] == '-') { //处理符号,s[0]是最高位的数字
        cout << '-';//如果为负数,先输出负号
        s.erase(0, 1);//删除s[0]到1的字符,也就是把负号删了
    }
    int count = 0; //用于记录当前位置
    for(int i = s.length() - 1; i >= 0; i--){ //添加逗号
        count++;
        if(count % 3 == 0 && i > 0){//三位
            s.insert(i, ",");//把逗号插在i前面
        }
    }
    cout << s;//输出s
}

1.using name std的作用是释放std命名空间中的变量名,函数名以及类型名,其中std是C++标准库的命名空间。

2.删除某位置 后一段长度的元素:

s.erase(int a,int n)

#include<iostream>
#include<cstring>
using namespace std;
int main(){
	string str="asddffggh";
	int len=str.length() ;
	str.erase(0,3);
	cout<<str<<endl;
	return 0; 
}
//输出dffggh 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值