练习二 1020 Prime Ring Problem

题目:
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.<br><br>Note: the number of first circle should always be 1.<br><br><img src=../../data/images/1016-1.gif><br>

Input
n (0 < n < 20).<br>

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.<br><br>You are to write a program that completes above process.<br><br>Print a blank line after each case.<br>

Sample Input
  
  
6<br>8<br>

Sample Output
  
  
Case 1:<br>1 4 3 2 5 6<br>1 6 5 2 3 4<br><br>Case 2:<br>1 2 3 8 5 6 7 4<br>1 2 5 8 3 4 7 6<br>1 4 7 6 5 8 3 2<br>1 6 7 4 3 8 5 2<br>
题目大意:输入一个 n 找出1~n的组合,使得相邻两个数之和为素数
解题思路: 这道题非常类似于N皇后问题,可以使用的深度优先搜索方法来解决, 虽然说打印要求是按照顺时针和逆时针顺序打印,其实按照从小到大的搜索顺序搜索后的结果就是符合输出顺序的,而且 由于是20以内的数字,所以判断质数的方法是直接打表后一个简单的循环判断一下是否为质数并 标记某个数字是否使用过,最终可求出结果。
感想:深搜问题,还好老师讲过类似题目,要不然肯定很难做出来。
代码:
#include<iostream>
#include<cstring>
#include<cstdio>
#include<cstdlib>
#include<iomanip>
using namespace std;
int num[21],mark[21],n;
int prime_num[12]={2,3,5,7,11,13,17,19,23,29,31,37}; //判断是否是质数,是返回1,不是返回0
int is_prime(int a)
{
    for(int i=0;i<12;i++)
    if(a==prime_num[i]) return 1;
    return 0;
}
void print_num()
{
    for(int i=1;i<n;i++)
    cout<<num[i]<<" ";
    cout<<num[n]<<" ";
}

int dfs(int pre,int post,int flag)
{
    if(!is_prime(pre+post)) return 0; //如果不符合,直接返回
    num[flag]=post;
    if(flag==n&&is_prime(post+1))
    {
        print_num();
        printf("\n");
        return 1;
    }
    mark[post]=0; //使用过了这个数字就标记为0
    for(int i=2;i<=n;i++)
    if(mark[i]!=0&&dfs(post,i,flag+1)) break;
    mark[post]=1;//标记位恢复原状
    return 0;
}
int main()
{
    int count,i;
    count=1;
    while(cin>>n)
    {
        for(int i=1;i<=n;i++)
        mark[i]=i;
        num[1]=1;
        cout<<"Case "<<count++<<":"<<endl;
        if(n==1)
			cout<<"1"<<endl;
        for(i=2;i<=n;i++)
        dfs(1,i,2);
        cout<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值