//scanf居然比cin快?//优先队列//Average Number------[NWPU][2018寒假作业][通用版]二G题

In a speech contest, when a contestant finishes his speech, the judges will then grade his performance. The staff remove the highest grade and the lowest grade and compute the average of the rest as the contestant’s final grade. This is an easy problem because usually there are only several judges.
Let’s consider a generalized form of the problem above. Given n positive integers, remove the greatest n1 ones and the least n2 ones, and compute the average of the rest.
Input
The input consists of several test cases. Each test case consists two lines. The first line contains three integers n1, n2 and n (1 ≤ n1, n2 ≤ 10, n1 + n2 < n ≤ 5,000,000) separate by a single space. The second line contains n positive integers ai (1 ≤ ai ≤ 108 for all i s.t. 1 ≤ i ≤ n) separated by a single space. The last test case is followed by three zeroes.
Output
For each test case, output the average rounded to six digits after decimal point in a separate line.
Sample Input
1 2 5
1 2 3 4 5
4 2 10
2121187 902 485 531 843 582 652 926 220 155
0 0 0
Sample Output
3.500000
562.500000

解题思路:
在发现了优先队列这种高级的数据结构之后就非常简单了。
把n1或n2加1个数放到优先队列里,每次再让最大或最小的数蹦出来,最后队列中就是最大的n1个数和最小的n2个数了。
因为如果把所有数都存起来会内存超限,所以直接把新输入的数加到sum里,最后再把队列里的数减掉就可以求平均值了。
因为ai很大,所以ai和sum都要用long long int型。

因为有long long int型,怕麻烦就用了cin、cout输入输出,结果居然超时了,换成scanf和printf就好了。
一直不知道scanf和printf比cin和cout快。
http://blog.csdn.net/zq_onlytime/article/details/44900081

#include<stdio.h>
#include<queue>
using namespace std;

long long int sum,a;
int n1,n2,n;
priority_queue<long long int> big,small;

int main()
{
    while(1)
    {
        scanf("%d%d%d",&n1,&n2,&n);
        if(n1==0&&n2==0&&n==0)
        {
            return 0;
        }
        sum=0;
        for(int i=1;i<=n;i++)
        {
            scanf("%lld",&a);
            sum+=a;
            big.push(-a);
            small.push(a);
            if(big.size()>n1 ) big.pop();
            if(small.size()>n2) small.pop();
        }
        for(int i=1;i<=n1;i++)
        {
            sum+=big.top();
            big.pop();
        }
        for(int i=1;i<=n2;i++)
        {
            sum-=small.top();
            small.pop();
        }
        printf("%.6lf\n",sum*1.0/(n-n1-n2));
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值