(2)G - stl 的 优先队列

In a speech contest, when a contestant finishes his speech, the judges will then grade his performance. The staff remove the highest grade and the lowest grade and compute the average of the rest as the contestant’s final grade. This is an easy problem because usually there are only several judges.

Let’s consider a generalized form of the problem above. Given n positive integers, remove the greatest n1 ones and the leastn2 ones, and compute the average of the rest.

Input

The input consists of several test cases. Each test case consists two lines. The first line contains three integersn1, n2 andn (1 ≤ n1, n2 ≤ 10, n1 +n2 < n ≤ 5,000,000) separate by a single space. The second line containsn positive integers ai (1 ≤ai ≤ 108 for all i s.t. 1 ≤ i ≤ n) separated by a single space. The last test case is followed by three zeroes.

Output

For each test case, output the average rounded to six digits after decimal point in a separate line.

Sample Input
1 2 5
1 2 3 4 5
4 2 10
2121187 902 485 531 843 582 652 926 220 155
0 0 0
Sample Output
3.500000
562.500000
Hint

This problem has very large input data. scanf andprintf are recommended for C++ I/O.

The memory limit might not allow you to store everything in the memory.

题意:输入n1 n2 n,表示有n个数,去掉n1个最大的数,n2个最小的数,我百度学习了一下优先队列,priority_queue是默认把数按从大到小存储。所以pop()会把大的数个拿出来,priori_queue<int ,vector<int>,greater<int > >        > >中间有空格, 是按从小到大排,pop()qu取出小的数,就可以记录下最小最大的几个数

#include<iostream>
#include<cstdio>
#include<queue>
using namespace std;
int main()
{
 int n1,n2,n,temp,i;
 double sum;
 while(scanf("%d%d%d",&n1,&n2,&n)&&n!=0)
 {
  sum=0;
  priority_queue<double>small;
  priority_queue<double,vector<double>,greater<double> >big;//保证精度
   for(i=0;i<n;i++)
   {
    scanf("%d",&temp);
    sum+=temp;//输入就加起来,和存到queue
    small.push(temp);
    big.push(temp);
    if(small.size()>n2)//就取出
    {
     small.pop();
    }
    if(big.size()>n1)
    {
     big.pop();
    }
    
   }
   for(i=0;i<n1;i++)
   {
    sum-=big.top();
    big.pop();
   }
   for(i=0;i<n2;i++)
   {
    sum-=small.top();
    small.pop();
   }
   sum=sum/(n-n1-n2);
   printf("%.6lf\n",sum);
   
 }
 return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值