To and Fro
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 4576 Accepted Submission(s): 3192
Problem Description
Mo and Larry have devised a way of encrypting messages. They first decide secretly on the number of columns and write the message (letters only) down the columns, padding with extra random letters so as to make a rectangular array of letters. For example, if the message is “There’s no place like home on a snowy night” and there are five columns, Mo would write down
t o i o y
h p k n n
e l e a i
r a h s g
e c o n h
s e m o t
n l e w x
Note that Mo includes only letters and writes them all in lower case. In this example, Mo used the character ‘x’ to pad the message out to make a rectangle, although he could have used any letter.
Mo then sends the message to Larry by writing the letters in each row, alternating left-to-right and right-to-left. So, the above would be encrypted as
toioynnkpheleaigshareconhtomesnlewx
Your job is to recover for Larry the original message (along with any extra padding letters) from the encrypted one.
t o i o y
h p k n n
e l e a i
r a h s g
e c o n h
s e m o t
n l e w x
Note that Mo includes only letters and writes them all in lower case. In this example, Mo used the character ‘x’ to pad the message out to make a rectangle, although he could have used any letter.
Mo then sends the message to Larry by writing the letters in each row, alternating left-to-right and right-to-left. So, the above would be encrypted as
toioynnkpheleaigshareconhtomesnlewx
Your job is to recover for Larry the original message (along with any extra padding letters) from the encrypted one.
Input
There will be multiple input sets. Input for each set will consist of two lines. The first line will contain an integer in the range 2. . . 20 indicating the number of columns used. The next line is a string of up to 200 lower case letters. The last input set is followed by a line containing a single 0, indicating end of input.
Output
Each input set should generate one line of output, giving the original plaintext message, with no spaces.
Sample Input
5 toioynnkpheleaigshareconhtomesnlewx 3 ttyohhieneesiaabss 0
Sample Output
theresnoplacelikehomeonasnowynightx thisistheeasyoneab
这算是一道字符串模拟,其实就是找规律。题意是将一个串以‘Z字形输入,以‘W’形输出。我用了矩阵存储,然后就是模拟。中间我写的有点复杂,不过没想出优化方法。
代码:
#include<stdio.h>
#include<string.h>
char map[200][100];
char s[210];
int main()
{
//freopen("in.txt","r",stdin);
int n;
while(scanf("%d",&n)!=EOF)
{
if(n==0) break;
//getchar();
scanf("%s",s);
int len=strlen(s);
int m=len/n;
int cnt=0;
while(cnt<len) //存入矩阵
{
for(int i=0;i<m;i++)
for(int j=0;j<n;j++)
{
map[i][j]=s[cnt];
cnt++;
}
}
for(int i=0;i<m;i++)
{
if(i%2==1) //将奇数行的顺序颠倒
{
for(int j=0;j<n/2;j++)
{
char ch=map[i][j];
map[i][j]=map[i][n-j-1];
map[i][n-j-1]=ch;
}
}
else
continue;
}
for(int i=0;i<n;i++)
for(int j=0;j<m;j++)
printf("%c",map[j][i]);
printf("\n");
}
return 0;
}
</span>