hdu 1701 ACMer

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1701

Problem Description
There are at least P% and at most Q% students of HDU are ACMers, now I want to know how many students HDU have at least?
 

Input
The input contains multiple test cases.
The first line has one integer,represent the number of test cases.
The following N lines each line contains two numbers P and Q(P < Q),which accurate up to 2 decimal places.
 

Output
For each test case, output the minumal number of students in HDU.
 

Sample Input
  
  
1 13.00 14.10
 

Sample Output
  
  
15
 

Source


开始写这道题的时候很坑啊,自己想多了。还对其向上和向下取整了。。因为总人数是整数,所以只需要暴力寻找满足最小和最大值有差距的一个值就好了。

代码:

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#include<string>
#include<math.h>
#include<stdlib.h>
#include<map>
#include<queue>
#define max(x,y)x>y?x:y
#define min(x,y)x<y?x:y
using namespace std;
const int maxn=60;
int dp[maxn][maxn][maxn];
int main()
{
   freopen("in.txt","r",stdin);
   int n;
   scanf("%d",&n);
   while(n--)
   {
       double p,q;
       scanf("%lf %lf",&p,&q);
       for(int i=1;;i++)
       {
           int t1=p*i/100;
           int t2=q*i/100;
           if(t1<t2)
           {
               printf("%d\n",i);
               break;
           }
       }
   }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值