hdu1701ACMer(基础)

43 篇文章 0 订阅

ACMer

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4336    Accepted Submission(s): 1982


Problem Description
There are at least P% and at most Q% students of HDU are ACMers, now I want to know how many students HDU have at least?
 

Input
The input contains multiple test cases.
The first line has one integer,represent the number of test cases.
The following N lines each line contains two numbers P and Q(P < Q),which accurate up to 2 decimal places.
 

Output
For each test case, output the minumal number of students in HDU.
 

Sample Input
  
  
1 13.00 14.10
 

Sample Output
  
  
15
 题目大意:hdu的acmer最多占学校总数的Q%,最少占P%,问学校的人数最少是多少?
首先,若设最少人数为sum,则当第一个满足sum*p% < sum*Q%时的sum的值即为最小sum值。
代码如下:
#include<stdio.h>
#include<math.h>
int main()
{
	int n,i;
	double p,q;
	scanf("%d",&n);
	while(n--)
	{
		int sum=0;
		scanf("%lf%lf",&p,&q);
		int num=q-p;
		i=1;
		while(1)
		{
			if((int)(p*i/100)<(int)(q*i/100))
			{
			 sum=i; break;
			}
			i++;
		}
	printf("%d\n",sum);
	}
return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

bokzmm

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值