【HDU - 1520 Cupcake】 树形DP

A - Cupcake


There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings. 
Input
Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form: 
L K 
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line 
0 0
Output
Output should contain the maximal sum of guests' ratings. 
Sample Input
7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0
Sample Output
5

题意:有一颗n个节点的无根树,给出每个节点的值和两点L,K之间的连线,K为L的父节点,现在有条件:如果选择了一个节点的值,那么就不能选择其儿子节点的值,如果这个节点没有被选择,那么可以选择其儿子节点的值。问在这种条件下,使得选择的值最大为多少。


分析:我们设一个dp[i][2]数组,dp[i][0]表示不选择当前节点时得到的最大值,dp[i][1]表示选择当前节点时得到的最大值,设一个vector数组vt[MX]记录该点的儿子节点,那么可以写出状态转移方程:


dp[i][0] += max(dp[vt[i][sz]][1], dp[vt[i][sz]][0])    表示不选择当前点时,对当前点儿子节点的选择方式

dp[i][1] += dp[vt[i][sz]][0]    表示选择当前点时,将其所有儿子节点不选择时的最大值


还有就是用一个fa[i]数组记录每个节点父节点的编号,便于下面找到根节点。


代码如下:

#include <map>
#include <cmath>
#include <queue>
#include <stack>
#include <vector>
#include <cstdio>
#include <string>
#include <cstring>
#include <iostream>
#include <algorithm>
#define LL long long

using namespace std;
const int MX = 6e3 + 5;
const int INF = 1e9 + 5;

int n;
int fa[MX];
int dp[MX][2];
vector<int> vt[MX];

void dfs(int rt) {
    int sz = vt[rt].size();
    for(int i = 0; i < sz; i++) {
        dfs(vt[rt][i]);
    }
    for(int i = 0; i < sz; i++) {
        dp[rt][1] += dp[vt[rt][i]][0];
        dp[rt][0] += max(dp[vt[rt][i]][0], dp[vt[rt][i]][1]);
    }
}

int main() {
    while(~scanf("%d", &n)) {
        memset(dp, 0, sizeof(dp));
        for(int i = 1; i <= n; i++) {
            scanf("%d", &dp[i][1]);
            fa[i] = i;
            vt[i].clear();
        }
        int u, v;
        while(~scanf("%d%d", &u, &v), u && v) {
            fa[u] = v;
            vt[v].push_back(u);
        }
        int root = 1;
        while(fa[root] != root) {
            root = fa[root];
        }
        dfs(root);
        printf("%d\n", max(dp[root][1], dp[root][0]));
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值