【HDU - 1385 Minimum Transport Cost】 floyd打印路径

C - Minimum Transport Cost


These are N cities in Spring country. Between each pair of cities there may be one transportation track or none. Now there is some cargo that should be delivered from one city to another. The transportation fee consists of two parts: 
The cost of the transportation on the path between these cities, and 

a certain tax which will be charged whenever any cargo passing through one city, except for the source and the destination cities. 

You must write a program to find the route which has the minimum cost. 

Input
First is N, number of cities. N = 0 indicates the end of input. 

The data of path cost, city tax, source and destination cities are given in the input, which is of the form: 

a11 a12 ... a1N 
a21 a22 ... a2N 
............... 
aN1 aN2 ... aNN 
b1 b2 ... bN 

c d 
e f 
... 
g h 

where aij is the transport cost from city i to city j, aij = -1 indicates there is no direct path between city i and city j. bi represents the tax of passing through city i. And the cargo is to be delivered from city c to city d, city e to city f, ..., and g = h = -1. You must output the sequence of cities passed by and the total cost which is of the form: 

Output
From c to d : 
Path: c-->c1-->......-->ck-->d 
Total cost : ...... 
...... 

From e to f : 
Path: e-->e1-->..........-->ek-->f 
Total cost : ...... 

Note: if there are more minimal paths, output the lexically smallest one. Print a blank line after each test case. 

Sample Input
5
0 3 22 -1 4
3 0 5 -1 -1
22 5 0 9 20
-1 -1 9 0 4
4 -1 20 4 0
5 17 8 3 1
1 3
3 5
2 4
-1 -1
0
Sample Output
From 1 to 3 :
Path: 1-->5-->4-->3
Total cost : 21

From 3 to 5 :
Path: 3-->4-->5
Total cost : 16

From 2 to 4 :
Path: 2-->1-->5-->4
Total cost : 17

题意:给出n个城市间的距离花费,距离为-1表示这两个城市间没有路可走,经过一个城市需要过路费cost[i],问从一个城市到另一个城市需要的最小花费以及路径。


分析:最小花费可以用floyd直接计算,现在关键是打印路径。我们用一个path[i][j]数组记录从城市i到城市j的下一步应该走到的城市,这样在floyd更新最小花费的时候直接更新path[i][j] = path[i][k]。最后在一个循环中就可以打印路径了。

代码如下:
#include <map>
#include <cmath>
#include <queue>
#include <stack>
#include <vector>
#include <cstdio>
#include <string>
#include <cstring>
#include <iostream>
#include <algorithm>
#define LL long long

using namespace std;
const int MX = 1e4 + 5;
const int INF = 1e9 + 5;

int mp[MX][MX];
int path[MX][MX];
int cost[MX];
int n;

void floyd(){
    for(int k = 1; k <= n; k++){
        for(int i = 1; i <= n; i++){
            for(int j = 1; j <= n; j++){
                if(mp[i][j] > mp[i][k] + mp[k][j] + cost[k]){
                    mp[i][j] = mp[i][k] + mp[k][j] + cost[k];
                    path[i][j] = path[i][k];
                }
                else if(mp[i][j] == mp[i][k] + mp[k][j] + cost[k]){
                    path[i][j] = min(path[i][j], path[i][k]);
                }
            }
        }
    }
}

int main(){
    while(~scanf("%d", &n), n){
        for(int i = 1; i <= n; i++){
            for(int j = 1; j <= n; j++){
                scanf("%d", &mp[i][j]);
                path[i][j] = j;
                if(mp[i][j] == -1)  mp[i][j] = INF;
            }
        }
        for(int i = 1; i <= n; i++){
            scanf("%d", &cost[i]);
        }
        floyd();
        int u, v;
        while(~scanf("%d%d", &u, &v), u != -1 && v != -1){
            printf("From %d to %d :\n", u, v);
            printf("Path: %d", u);
            int tmp = u;
            while(tmp != v){
                printf("-->%d", path[tmp][v]);
                tmp = path[tmp][v];
            }
            printf("\nTotal cost : %d\n\n", mp[u][v]);
        }
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值