1013. Battle Over Cities (25)(并查集/dfs)

1013. Battle Over Cities (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city1-city2 and city1-city3. Then if city1 is occupied by the enemy, we must have 1 highway repaired, that is the highway city2-city3.

Input

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input
3 2 3
1 2
1 3
1 2 3
Sample Output
1
0
0
题目大致意思:给出n个城市之间有相互连接的m条道路,当删除一个城市和其连接的道路的时候,问其他几个剩余的城市至少要添加多少个路线才能让它们重新变为连通图。也就是删除一个节点及其所连道路,求剩余节点的联通图的个数。

一、并查集:

#include<iostream>
using namespace std;
int n,m,k;
const int maxsize=1002;
int node[maxsize];
int connect[50000000][2];
int find_root(int a)//寻找根节点 
{
	while(node[a]!=a)
		a=node[a];
	return a;
}
void non_con(int v,int ct)
{
	for(int i=1;i<=n;++i)//并查集数组初始化 
		node[i]=i;
		
	for(int i=0;i<m;++i)
	{
		if(connect[i][0]!=v && connect[i][1]!=v)
		{
			int a=find_root(connect[i][0]);
			int b=find_root(connect[i][1]);
			if(a!=b)
			{	
				node[a]=b;
				//--ct;
			}
		}
	}
	//return ct;
} 
int main()
{
	//freopen("in.txt","r",stdin);
	cin>>n>>m>>k;
	for(int i=0;i<m;++i)
		cin>>connect[i][0]>>connect[i][1];
	int a;
	for(int i=0;i<k;++i)
	{
		cin>>a;
	//	cout<<non_con(a,n-2)<<endl;
		non_con(a,n-2);
		int ct=0;
		for(int i=1;i<=n;++i)
		{
			if(i!=a && node[i]==i)
			++ct;
		}
		cout<<ct-1<<endl;
	}

	return 0;
}

提交结果:



原因分析:由于在fing_rooot()函数内部不是用递归实现的,复杂度有点大,以至于测试案例最后一个因运行超时而错误。之前是找错误,是因为connect[maxsize][maxsize]数组开的不够大。了解一下别人写的并查集方法,之所以能通过是因为求根节点的函数内部用递归实现。

正确通过的代码:

#include<iostream>
using namespace std;
int n,m,k;
const int maxsize=1002;
int node[maxsize];
int connect[50000000][2];//保存连接的二个城市节点 
int find_root(int a)//寻找根节点 
{
	while(node[a]!=a)
		a=node[a];
	return a;
}
int get_root(int a)//递归实现,内部复杂度降低(很重要) 
{
	if(node[a]!=a)
	node[a]=get_root(node[a]);
	return node[a];
}
void non_con(int v)
{
	for(int i=1;i<=n;++i)//并查集数组初始化 
		node[i]=i;
		
	for(int i=0;i<m;++i)
	{
		if(connect[i][0]!=v && connect[i][1]!=v)
		{
			int a=get_root(connect[i][0]);
			int b=get_root(connect[i][1]);
			if(a!=b)
			{	
				node[a]=b;
				//--ct;
			}
		}
	}
	//return ct;
} 
int main()
{
	//freopen("in.txt","r",stdin);
	cin>>n>>m>>k;
	for(int i=0;i<m;++i)
		cin>>connect[i][0]>>connect[i][1];
	int a;
	for(int i=0;i<k;++i)
	{
		cin>>a;
	//	cout<<non_con(a,n-2)<<endl;
		non_con(a);
		int ct=0;
		for(int i=1;i<=n;++i)
		{
			if(i!=a && node[i]==i)
			++ct;
		}
		cout<<ct-1<<endl;
	}

	return 0;
}

正确结果:


粘一下别人的代码:

#include<iostream>
#include<cstdio>
//并查集做,AC代码
using namespace std;

int n,m,k;
int father[1001];
int road[500001][2];
//用的巧妙,road[i][0]和road[i][1]表示第i条road的两端
void makeset(int num){
    int i;
    for(i=0;i<=num;i++)
        father[i]=i;
}
int findset(int x){
    if(x!=father[x]) father[x]=findset(father[x]);
    return father[x];
}
void joinset(int x,int y){
    x=findset(x);
    y=findset(y);
    if(x==y) return ;
    else{
        father[y]=x;
    }
}

int main(){
    freopen("in.txt","r",stdin);
    int i,tmp,j;
    while(cin>>n>>m>>k){
        for(i=0;i<m;i++){
            cin>>road[i][0]>>road[i][1];
        }

        for(i=0;i<k;i++){
            makeset(n);
            cin>>tmp;
            for(j=0;j<m;j++){
                if(tmp!=road[j][0] && tmp!=road[j][1]) joinset(road[j][0],road[j][1]);
            }

            int num=0;
            for(j=1;j<=n;j++){
                if(father[j]==j) num++;
            }
            cout<<num-2<<endl;//去掉一个结点-1,连接-1
        }
    }
    return 0;
}

二、dfs法

#include <cstdio>  
#include <cstring>  
#define MAX 1000  
int edge[MAX][MAX];  
int visited[MAX];  
int n, m, k;  
  
void dfs(int t){  
    visited[t] = 1;  
    for (int i = 1; i <= n; ++i){  
        if (!visited[i] && edge[i][t] == 1)  
            dfs(i);  
    }  
}  
  
int main(){  
    scanf("%d%d%d", &n, &m, &k);  
    int a, b;  
    for (int i = 0; i < m; ++i){  
        scanf("%d%d", &a, &b);  
        edge[a][b] = 1;  
        edge[b][a] = 1;  
    }  
    int c;  
    while (k--){  
        int count = 0;  
        scanf("%d", &c);  
        memset(visited, 0, sizeof(visited));  
        visited[c] = 1;  
        for (int i = 1; i <= n; ++i){  
            if (visited[i] == 0){  
                dfs(i);  
                count++;  
            }  
        }  
        printf("%d\n", count-1);  
    }  
    return 0;  
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值