1013. Battle Over Cities

思路:对一个图,如果去掉一个结点,则需要多少边使得图变成连通的。显然增加的边是连通分支的个数减1。由于此题有多问,因此可以设置某个结点为禁忌点,即此结点在判断连通分支时直接当作已经判断过的节点处理。这样不修改图的数据,有利于下次求解。

练习:图的连通分支判断

题目描述:

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city1-city2 and city1-city3. Then if city1 is occupied by the enemy, we must have 1 highway repaired, that is the highway city2-city3.

Input

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input
3 2 3
1 2
1 3
1 2 3
Sample Output
1
0
0
参考代码:

#include <iostream>
#include <vector>
#include <map>
#include <algorithm>
using namespace std;
#include <string.h>

template<typename edgeType,typename nodeType=int>
class CGraph
{
private:
  //定义结点类型
  struct TNode
  {
    int n;//边后面顶点
    edgeType weight;//权重
  };
public:
  CGraph()
  {
    this->adj=NULL;
    this->size=0;
  }
  CGraph(const CGraph &other)
  {
    this->size=other.size;
    this->data=new vector<TNode>[this->size];
    for(int i=0;i<this->size;i++)
      this->data[i]=other->data[i];
  }
  ~CGraph()
  {
    delete []this->adj;
  }
public:
  void SetSize(int size)
  {
    this->size=size;
    delete []this->adj;
    this->adj=new vector<TNode>[this->size];
  }
  //设置无向边
  void SetSide(nodeType u,nodeType v,edgeType l)
  {
    int uID;
    if(Node2ID.find(u)==Node2ID.end()) 
    {
      uID=Node2ID.size();
      Node2ID[u]=uID;
      ID2Node[uID]=u;
    }
    else
    {
      uID=Node2ID[u];
    }
    int vID;
    if(Node2ID.find(v)==Node2ID.end()) 
    {
      vID=Node2ID.size();
      Node2ID[v]=vID;
      ID2Node[vID]=v;
    }
    else
    {
      vID=Node2ID[v];
    }
    TNode node;
    node.n=vID;
    node.weight=l;
    adj[uID].push_back(node);
    node.n=uID;
    node.weight=l;
    adj[vID].push_back(node);
  }
  
  
  //统计有多少连通分支
  int GetParts()
  {
    bool *found=new bool[this->size];
    memset(found,0,sizeof(bool)*this->size);
    int parts=0;
    for(int i=0;i<this->size;i++)
      if(found[i]==false)
      {
        parts++;
        InnerTraversal(i,found);
      }
    return parts;
  }
  //统计有多少连通分支,带有禁忌表
  int GetParts(vector<nodeType> &taboo)
  {
    bool *found=new bool[this->size];
    memset(found,0,sizeof(bool)*this->size);
    for(typename vector<nodeType>::iterator it=taboo.begin();it!=taboo.end();it++)
      found[Node2ID[*it]]=true;
    int parts=0;
    for(int i=0;i<this->size;i++)
      if(found[i]==false)
      {
        parts++;
        InnerTraversal(i,found);
      }
    return parts;
  }
  //统计有多少连通分支,带有禁忌结点
  int GetParts(nodeType tabooNode)
  {
    vector<nodeType> taboo;
    taboo.push_back(tabooNode);
    return GetParts(taboo);
  }
private:
  //从u结点遍历其连通图
  void InnerTraversal(int u,bool *found)
  {
    found[u]=true;
    for(typename vector<TNode>::iterator it=adj[u].begin();it!=adj[u].end();it++)
      if (found[it->n]==false)
        InnerTraversal(it->n,found);
  }
private:
  vector<TNode> *adj;//边的数据
  map<nodeType,int> Node2ID;//结点=>编码
  map<int,nodeType> ID2Node;//编码=>结点
  int size;  //顶点的个数
};

// --------------我是分界线-------------------
int main()
{
    CGraph<int> graph;
  int n,m,k;
  while(cin>>n>>m>>k)
    {
    graph.SetSize(n);
    int u,v,i;
    for(i=0;i<m;i++)
    {
            cin>>u>>v;
      graph.SetSide(u,v,1);
    }
    int *repaired=new int[n+1];
    for(i=1;i<=n;i++)
      repaired[i]=-1;
    for(i=1;i<=k;i++)
    {
      int t;
      cin>>t;
      if(repaired[t]<0)
        repaired[t]=graph.GetParts(t);
      cout<<repaired[t]-1<<endl;
    }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值