1015. Reversible Primes (20)

1015. Reversible Primes (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (< 105) and D (1 < D <= 10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line "Yes" if N is a reversible prime with radix D, or "No" if not.

Sample Input:
73 10
23 2
23 10
-2
Sample Output:
Yes
Yes
No
题型:素数

题目大意:如果一个数本身是素数,而且在d进制下反转后的数在十进制下也是素数,就输出Yes,否则就输出No
分析:判断输入是否为负数,判断n是否为素数,把n转换为d进制再反过来转换为10进制,判断是否为素数

#include<iostream>
#include<cmath>
using namespace std;
int n,radix;
bool prime(int num)
{
	if(num<2) return false;//之前这一句没写,导致一个案例没有通过,还是的细心啊 
	if(num==2 || num==3)
	return true;
	if(num%2==0)//去掉偶数 
	return false;
	for(int i=3;i<=sqrt(num);i+=2)//遍历到到这个数的二次根即可 
	{
		if(num%i==0)
		return false;
	}
	return true;
}
int change(int num)
{
	int ch[50];
	int index=0;
	while(num!=0)
	{
		ch[index++]=num%radix;
		num/=radix;
	}
	num=0;
	for(int i=0;i<index;++i)
	{
		num=num*radix+ch[i];
	}
	return num;
	/*还可以这样子写
	int n=0;
	while(num!=0)
	{
		n=radix*n+num%radix;
		num/=rasix;
	}
	return n;
	*/
}
int main()
{
	//freopen("in.txt","r",stdin);
	cin>>n; 
	while(n>0)
	{
		cin>>radix;
		if(prime(n)==false)
		{
			cout<<"No"<<endl;
		}
		else
		{
			if(prime(change(n))==true)
			cout<<"Yes"<<endl;
			else
			cout<<"No"<<endl;
		}
		cin>>n;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值