1115. Counting Nodes in a BST (30)


时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than or equal to the node's key.
  • The right subtree of a node contains only nodes with keys greater than the node's key.
  • Both the left and right subtrees must also be binary search trees.

Insert a sequence of numbers into an initially empty binary search tree. Then you are supposed to count the total number of nodes in the lowest 2 levels of the resulting tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=1000) which is the size of the input sequence. Then given in the next line are the N integers in [-1000 1000] which are supposed to be inserted into an initially empty binary search tree.

Output Specification:

For each case, print in one line the numbers of nodes in the lowest 2 levels of the resulting tree in the format:

n1 + n2 = n

where n1 is the number of nodes in the lowest level, n2 is that of the level above, and n is the sum.

Sample Input:
9
25 30 42 16 20 20 35 -5 28
Sample Output:
2 + 4 = 6

首先建树。然后dfs。


#include<stdio.h>
#include<stdlib.h>
int cou[1010]={0};
int deepest=0;
typedef struct Node *node;
struct Node{
	int x;
	node left;
	node right;
};
node insert(node T,int x){
	if(!T){
		T=(node)malloc(sizeof(struct Node));
		T->x=x;
		T->left=T->right=NULL;
	}
	else{
		if(x<=T->x){
			T->left=insert(T->left,x);
		}
		else{
			T->right=insert(T->right,x);
		}
	}
	return T;
}
void dfs(node T,int depth){
	if(!T){
		return;
	}
	if(depth>deepest){
		deepest=depth;
	}
	cou[depth]++;
	dfs(T->left,depth+1);
	dfs(T->right,depth+1);
}
int main(){
	int n,i,x;
	scanf("%d",&n);
	node T=NULL;
	for(i=0;i<n;i++){
		scanf("%d",&x);
		T=insert(T,x); 
	}
	dfs(T,1);
	printf("%d + %d = %d",cou[deepest],cou[deepest-1],cou[deepest]+cou[deepest-1]);
}


#include<stdio.h>
#include<stdlib.h>
#include<queue>
using namespace std;
int cou1=0,cou2=0,deepest=0;
typedef struct Node *node;
struct Node{
	int x;
	int depth;
	node left;
	node right;
};
node build(node T,int x){
	if(T==NULL){
		T=(node)malloc(sizeof(struct Node));
		T->x=x;
		T->left=T->right=NULL;
	}
	else if(x<=T->x){
		T->left=build(T->left,x);
	}
	else{
		T->right=build(T->right,x);
	}
	return T;
}
void inorder(node T){
	if(T){
		inorder(T->left);
		if(T->depth==deepest){
			cou1++;
		}
		else if(T->depth==deepest-1){
			cou2++;
		}
		inorder(T->right);
	}
}
int main(){
	int n,i,x;
	scanf("%d",&n);
	node T=NULL;
	for(i=0;i<n;i++){
		scanf("%d",&x);
		T=build(T,x);
	}
	queue<node>q;
	T->depth=1;
	q.push(T);
	while(!q.empty()){
		node head=q.front();
		if(head->depth>deepest){
			deepest=head->depth;
		}
		q.pop();
		if(head->left!=NULL){
			head->left->depth=head->depth+1;
			q.push(head->left);
		}
		if(head->right!=NULL){
			head->right->depth=head->depth+1;
			q.push(head->right);
		}
	}
	inorder(T);
	printf("%d + %d = %d",cou1,cou2,cou1+cou2);
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值