1144. The Missing Number (20)

1144. The Missing Number (20)

时间限制
150 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given N integers, you are supposed to find the smallest positive integer that is NOT in the given list.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<= 105). Then N integers are given in the next line, separated by spaces. All the numbers are in the range of int.

Output Specification:

Print in a line the smallest positive integer that is missing from the input list.

Sample Input:
10
5 -25 9 6 1 3 4 2 5 17
Sample Output:
7

这题不就是2018 408考研数据结构真题吗

自己用map暴力了一点,后面参考dalao题解,应该是最优的

#include<stdio.h>
#include<map>
#include<limits.h>
using namespace std;
map<int,int>mp;
int maxn=INT_MAX;
int main(){
	int n,i,tmp;
	scanf("%d",&n);
	for(i=0;i<n;i++){
		scanf("%d",&tmp);
		mp[tmp]=1;
	}
	for(i=1;i<=maxn;i++){
		if(mp[i]==0){
			printf("%d",i);break;
		}
	}
} 

dalao题解:

#include <bits/stdc++.h>
using namespace std;
int main()
{
    int n,val;
    vector<int> A;
    scanf("%d",&n);
    while(n--){
        scanf("%d",&val);
        if(val>0) A.push_back(val);
    }
    n=A.size();
    for(int i=0;i<n;++i){
        while(A[i]<=n&&A[i]!=A[A[i]-1]) swap(A[i],A[A[i]-1]);//妙啊,把正数调整到对应的下标 
    }
    for(int i=0;i<n;++i){
        if(A[i]!=i+1){
            printf("%d\n",i+1);
            return 0;
        }
    }
    printf("%d\n",n+1);
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值