A simple math problem

A -- A simple math problem

Time Limit:2s Memory Limit:128MByte

Submissions:1063Solved:173

DESCRIPTION

You have a sequence anan, which satisfies:

Now you should find the value of 10an⌊10an⌋.

INPUT
The input includes multiple test cases. The number of test case is less than 1000.Each test case contains only one integer n(1n109)n(1≤n≤109)
OUTPUT
For each test case, print a line of one number which means the answer.
SAMPLE INPUT
5
20
1314
SAMPLE OUTPUT
5
21
1317

题意:让求10^an.

#include <bits/stdc++.h>

using namespace std;

int main()
{
    int n;
    while(~scanf("%d",&n)){
        int t = 0;
        if(n-1>=10)
            t = 1;
         if(n-1>=99)
            t = 2;
        if(n-1>=998)
            t = 3;
         if(n-1>=9997)
            t = 4;
         if(n-1>=99996)
            t = 5;
        if(n-1>=999995)
            t = 6;
         if(n-1>=9999994)
            t = 7;
         if(n-1>=99999993)
            t = 8;
         if(n-1>=999999992)
            t = 9;
        printf("%d\n",n+t);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值