HDU-4006 The kth great number

http://acm.hdu.edu.cn/showproblem.php?pid=4006

The kth great number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 14511    Accepted Submission(s): 5619

Problem Description

Xiao Ming and Xiao Bao are playing a simple Numbers game. In a round Xiao Ming can choose to write down a number, or ask Xiao Bao what the kth great number is. Because the number written by Xiao Ming is too much, Xiao Bao is feeling giddy. Now, try to help Xiao Bao.

Input

There are several test cases. For each test case, the first line of input contains two positive integer n, k. Then n lines follow. If Xiao Ming choose to write down a number, there will be an " I" followed by a number that Xiao Ming will write down. If Xiao Ming choose to ask Xiao Bao, there will be a "Q", then you need to output the kth great number.

Output

The output consists of one integer representing the largest number of islands that all lie on one line.

Sample Input

8 3

I 1

I 2

I 3

Q

I 5

Q

I 4

Q

Sample Output

1 2 3

Hint

Xiao Ming won't ask Xiao Bao the kth great number when the number of the written number is smaller than k. (1=<k<=n<=1000000).

题目大意:n次操作,I为写下数字,Q为查询第K位大的数为多少

思路:优先队列或者multiset容器实现。

set和multiset会根据特定的排序原则将元素排序。两者不同之处在于,multisets允许元素重复,而set不允许重复。

故本题可维护一个multiset容器,当元素个数超过k个时,删除最小的元素,保证容器里始终仅有k个元素,此时,第一个元素即为所要查询的数。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <set>
using namespace std;
#define MAXN 100100
int main()
{
    int n,k;
    while(~scanf("%d %d",&n,&k))
    {
        char c[3];
        multiset<int> s;//默认从小到大排序,平衡二叉树实现
        while(n--)
        {
            scanf("%s",c);//缓冲多余空格
            if(c[0]=='I')
            {
                int x;
                scanf("%d",&x);
                s.insert(x);
                while(s.size()>k)
                {
                    s.erase(s.begin());//删除最小的元素
                }
            }
            else
            {
                printf("%d\n",*s.begin());
            }
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值