POJ - 2955 Brackets (区间DP)

Brackets

Description

We give the following inductive definition of a “regular brackets” sequence:

  • the empty sequence is a regular brackets sequence,
  • if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
  • if a and b are regular brackets sequences, then ab is a regular brackets sequence.
  • no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1i2, …, im where 1 ≤ i1 < i2 < … < im ≤ nai1ai2 … aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters ()[, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end

Sample Output

6
6
4
0
6



题意:给你一堆括号,要你求出最大匹配数,经典的括号匹配DP问题。



解题思路:区间DP问题,首先枚举区间,根据题目第二个条件,如果符合则匹配数+2,根据题目第三个条件还要进行中间分隔,枚举所有情况。dp[i][j]代表i到j这个区间的最大匹配数,那么如果s[i]==s[j],dp[i][j]=dp[i+1][j-1]+2,然后我们再枚举中间截断的情况,

dp[i][j]=max(dp[i][j],dp[i][k]+dp[k+1][j]),详见代码。


#include<iostream>
#include<memory.h>
#include<string>
using namespace std;

string str;
int dp[105][105];//i到j这个区间的最大匹配数

int main(){

    while(cin>>str){
        if(str=="end")
            break;

        memset(dp,0,sizeof(dp));

        //枚举区间长度,必须要从小到大枚举
        for(int len=2;len<=str.size();len++){

            //l,r为左右标记,两个标记不断地右移
            for(int l=0,r=len-1;r<str.size();l++,r++){

                //题目第二个条件
                if((str[l]=='('&&str[r]==')')||(str[l]=='['&&str[r]==']'))
                    dp[l][r]=dp[l+1][r-1]+2;
                
                //题目第三个条件,枚举从中间截断的情况即可,注意边界
                for(int z=l;z<r;z++)
                    dp[l][r]=max(dp[l][r],dp[l][z]+dp[z+1][r]);
            }

        }

        cout<<dp[0][str.size()-1]<<endl;

    }





}







评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值