PAT_甲级_1049

1049 Counting Ones

The task is simple: given any positive integer N, you are supposed to count the total number of 1’s in the decimal form of the integers from 1 to N. For example, given N being 12, there are five 1’s in 1, 10, 11, and 12.

Input Specification:
Each input file contains one test case which gives the positive N (≤2​30​​ ).

Output Specification:
For each test case, print the number of 1’s in one line.

Sample Input:
12
Sample Output:
5

#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<string>
#include<string.h>
using namespace std;
int main()
{
    string num;
    int _count = 0;
    cin >> num;
    int len = num.size();
    for (int i = 0; i < len; i++) {
        string pre = num.substr(0, i);
        string post = num.substr(i + 1, len - i + 1);
        int temp = 1;
        for (int j = 0; j < post.size(); j++) {
            temp *= 10;
        }
        if (num[i] == '0') {
            _count += (atoi(pre.c_str())) * temp;
        } else if (num[i] == '1') {
            _count += ((atoi(pre.c_str())) * temp + atoi(post.c_str()) + 1);
        } else {
            _count += (atoi(pre.c_str()) + 1) * temp;
        }
    }

    cout << _count;
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值