PAT_甲级_1015

1015 Reversible Primes

A reversible prime in any number system is a prime whose “reverse” in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (<10​5​​ ) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:
The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:
For each test case, print in one line Yes if N is a reversible prime with radix D, or No if not.

Sample Input:

73 10
23 2
23 10
-2

Sample Output:

Yes
Yes
No

这题主要是读懂题目意思

#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<vector>
#include<math.h>
using namespace std;
vector<int> arr;
int Is_prime(int a)
{
    int temp = int(sqrt(a * 1.0));
    if (a <= 1) {
        return 0;
    }
    for (int i = 2; i <= temp; i++) {
        if (a % i == 0) {
            return 0;
        }
    }
    return 1;
}

int main()
{
    int m, n;
    while (scanf("%d", &m) != EOF) {
        arr.clear();
        if (m < 0) {
            return 0;
        } else {
            scanf("%d", &n);
        }
        if (Is_prime(m) == 0) {
            cout << "No" << endl;
            continue;
        }
        while (m) {
            int r = m % n;
            m = m / n;
            arr.push_back(r);
        }
        int num_now = 0;
        int temp_b = 1;
        reverse(arr.begin(), arr.end());
        for (int i = 0; i < arr.size(); i++) {
            num_now += arr[i] * temp_b;
            temp_b *= n;
        }
        if (Is_prime(num_now)) {
            cout << "Yes" << endl;
        } else {
            cout << "No" << endl;
        }
    }


    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值