5-13 Insert or Merge (25分)

5-13 Insert or Merge   (25分)

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Merge sort works as follows: Divide the unsorted list into N sublists, each containing 1 element (a list of 1 element is considered sorted). Then repeatedly merge two adjacent sublists to produce new sorted sublists until there is only 1 sublist remaining.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer NN (\le 100100). Then in the next line, NN integers are given as the initial sequence. The last line contains the partially sorted sequence of the NN numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either "Insertion Sort" or "Merge Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resuling sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

Sample Output 1:

Insertion Sort
1 2 3 5 7 8 9 4 6 0

Sample Input 2:

10
3 1 2 8 7 5 9 4 0 6
1 3 2 8 5 7 4 9 0 6

Sample Output 2:

Merge Sort

1 2 3 8 4 5 7 9 0 6

只要会插入排序和非递归的归并排序就可以了,正好没怎么写过非递归的归并排序。要注意的就是继续执行一步的时候一定要和之前不同。

#include<iostream>
#include<algorithm>
using namespace std;
int n,flag;
bool judge(int x[],int y[])
{
	for(int i=0;i<n;i++)
	{
		if(x[i]!=y[i])
			return false;
	}
	return true;
}
int main()
{
	int a[105],b[105],c[105];
	cin>>n;
	for(int i=0;i<n;i++)
	{
		cin>>a[i];
		c[i]=a[i];
	}
	for(int i=0;i<n;i++)
	{
		cin>>b[i];
	}
	for(int i=0;i<n;i++)
	{
		sort(a,a+i+1);
		if(judge(a,b))
		{
			cout<<"Insertion Sort"<<endl;
			for(int j=i+1;j<n;j++)
			{
				sort(a,a+j+1);
				if(!judge(a,b))
				{
					for(int k=0;k<n;k++)
					{
						if(k!=n-1)
							cout<<a[k]<<" ";
						else
							cout<<a[k]<<endl;
					}
					break;
				}
			}
			flag=1;
			break;
		}
	}
	if(!flag)
	{
		cout<<"Merge Sort"<<endl;
		for(int i=2;i<=n;i*=2)
		{
			int j;
			for(j=0;j+i<=n;j+=i)
			{
				sort(c+j,c+j+i);
			}
			sort(c+j,c+n);
			if(judge(c,b))
					flag=1;
				if(flag&&!judge(c,b))
				{
					for(int l=0;l<n;l++)
					{
						if(l!=n-1)
							cout<<c[l]<<" ";
						else
							cout<<c[l]<<endl;
					}
					break;
				}
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

没想好叫什么名字

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值