hdu-2136-Largest prime factor [素数筛]


题目链接:http://acm.split.hdu.edu.cn/showproblem.php?pid=2136



Largest prime factor



Problem Description
Everybody knows any number can be combined by the prime number.
Now, your task is telling me what position of the largest prime factor.
The position of prime 2 is 1, prime 3 is 2, and prime 5 is 3, etc.
Specially, LPF(1) = 0.
 

Input
Each line will contain one integer n(0 < n < 1000000).
 

Output
Output the LPF(n).
 

Sample Input
  
  
1 2 3 4 5
 

Sample Output
  
  
0 1 2 1 3

 
题目分析:设1的序号为0,2的序号为1,3的序号为2,5的序号为3,以此类推..要求输出所给定的数n的最大质因子在素数表的位置,0<n<1000000。 用素数筛进行打表就可以了。


#include<iostream>
#include<cstring>
using namespace std;
const int maxx=1000001;
int prim[maxx];
int main()
{
    int i,j,n;
    memset(prim,0,sizeof(prim));
	int cnt=1;
	for(i=2;i<maxx;i++)
	{
		if(prim[i]==0)
		{
			prim[i]=cnt;
			for(j=i*2;j<maxx;j+=i)
			{
				prim[j]=cnt;
			}
			cnt++;
		}	
	}
	while(~scanf("%d",&n))
    {
		cout<<prim[n]<<endl;
	}	
    return 0;
}



#include<iostream>
#include<cstring>
using namespace std;
const int maxx=1000001;
int prim[maxx];
int main()
{
    int i,j,n;
    memset(prim,0,sizeof(prim));
	int cnt=1;
	for(i=2;i<maxx;i++)
	{
		if(prim[i]==0)
		{
			for(j=i;j<maxx;j+=i)
			{
				prim[j]=cnt;
			}
			cnt++;
		}	
	}
	while(~scanf("%d",&n))
    {
		cout<<prim[n]<<endl;
	}	
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值