PAT (Advanced Level) Practice — 1013 Battle Over Cities (25 分)

题目链接:https://pintia.cn/problem-sets/994805342720868352/problems/994805500414115840

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city​1​​-city​2​​ and city​1​​-city​3​​. Then if city​1​​ is occupied by the enemy, we must have 1 highway repaired, that is the highway city​2​​-city​3​​.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing Knumbers, which represent the cities we concern.

Output Specification:

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:

3 2 3
1 2
1 3
1 2 3

Sample Output:

1
0
0

:题意  n个城市,m条路线,然后去掉某一个城市,即每个城市通向其他城市的路都断掉,问如果再次构成连通图需要添加几条路?

:思路  并查集,计算目前有多少个连通块,想要整个连通需要再添加的路线数 为连通块数目(即根节点的数目)-1。

不要用cin cout 否则最后一个点会超时。

#include<iostream>
#include<cstdio>
using namespace std;
const int maxx=1001;
int a[maxx*maxx],b[maxx*maxx];
int pre[maxx];
int n,m,k;
int find(int r){
	if(pre[r]==r){
		return r;
	}else{
		pre[r]=find(pre[r]);
		return pre[r];
	}
}
void merge(int u,int v){
	int r1=find(u);
	int r2=find(v); 
	if(r1!=r2){
		pre[r2]=r1;
	}
}
void sol(int x){
	for(int i=1;i<=n;i++){
		pre[i]=i;
	}
	for(int i=0;i<m;i++){
		if(a[i]==x||b[i]==x){
			continue;                     
		}
		merge(a[i],b[i]);
	}
	int ans=0;
	for(int i=1;i<=n;i++){
		if(i==x){
			continue;
		}else{
			if(find(i)==i){
				ans++;
			}
		}
	}
	printf("%d\n",ans-1);
}
int main(){
	scanf("%d%d%d",&n,&m,&k);
	for(int i=0;i<m;i++){
		scanf("%d%d",&a[i],&b[i]);
	}
	int x; 
	for(int i=0;i<k;i++){
		scanf("%d",&x);
		sol(x); 
	}
	return 0;
} 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值