Genealogical tree(POJ-2367)

Genealogical tree
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5436 Accepted: 3563 Special Judge

Description

The system of Martians' blood relations is confusing enough. Actually, Martians bud when they want and where they want. They gather together in different groups, so that a Martian can have one parent as well as ten. Nobody will be surprised by a hundred of children. Martians have got used to this and their style of life seems to them natural. 
And in the Planetary Council the confusing genealogical system leads to some embarrassment. There meet the worthiest of Martians, and therefore in order to offend nobody in all of the discussions it is used first to give the floor to the old Martians, than to the younger ones and only than to the most young childless assessors. However, the maintenance of this order really is not a trivial task. Not always Martian knows all of his parents (and there's nothing to tell about his grandparents!). But if by a mistake first speak a grandson and only than his young appearing great-grandfather, this is a real scandal. 
Your task is to write a program, which would define once and for all, an order that would guarantee that every member of the Council takes the floor earlier than each of his descendants.

Input

The first line of the standard input contains an only number N, 1 <= N <= 100 — a number of members of the Martian Planetary Council. According to the centuries-old tradition members of the Council are enumerated with the natural numbers from 1 up to N. Further, there are exactly N lines, moreover, the I-th line contains a list of I-th member's children. The list of children is a sequence of serial numbers of children in a arbitrary order separated by spaces. The list of children may be empty. The list (even if it is empty) ends with 0.

Output

The standard output should contain in its only line a sequence of speakers' numbers, separated by spaces. If several sequences satisfy the conditions of the problem, you are to write to the standard output any of them. At least one such sequence always exists.

Sample Input

5
0
4 5 1 0
1 0
5 3 0
3 0

Sample Output

2 4 5 3 1


题目大意:

    火星人有着树状的父子关系,数据给出第i个火星人的所有后代的代号(有可能是儿子,也有可能是孙子等),你需要给出一种发言顺序,在此番发言顺序中,后代不允许比祖先先发言。

解题思路:

①拓扑排序,需要注意的是例如一个父亲有5个儿子,5个儿子都没有后代,那么父亲发言后,5个儿子都需要发言。

②用了深搜,二维数组记录输入,横着所有是子孙的都标记“1”,那竖着看的话,标“1 ”的肯定就是祖先们喽 ~

③ed数组记录所有已经发过言的祖先,例如:小明for循环到有祖先还没发言,就深搜他,让祖先先发言,要不小明没法发言了……

④肯定有没子孙的单身狗,在输入的时候把它们全部入队列,然后一个一个bfs!


代码如下:


#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
queue<int>q;
queue<int>p;
int ed[103];
int map[103][103];
void dfs(int x);
int n,m;
int main()
{
	while(~scanf("%d",&n))
	{
		memset(ed,0,sizeof(ed));
		memset(map,0,sizeof(map));
		for(int i=1 ; i<=n ; i++)
		{	
			int amount = 0;
			while(scanf("%d",&m),m)
			{
				map[i][m] = 1;
				amount++;
			} 
			if(!amount)
			p.push(i);
		}
		while(!p.empty())
		{
			dfs(p.front());
			p.pop();
		}
		while(!q.empty())
		{
			printf("%d%c",q.front(),q.size()==1?'\n':' ');
			q.pop();
		}
	}
	return 0;
}
void dfs(int x)
{
	for(int i=1 ; i<=n ; i++)
	{
		if(map[i][x] && !ed[i])
		dfs(i);
	}
	if(!ed[x])
	{
		q.push(x);
		ed[x] = 1;
	}
}

题目传送门

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值