PAT (Advanced Level) Practice 1031 Hello World for U (20 分)(C++)(甲级)

1031 Hello World for U (20 分)

Given any string of N (≥5) characters, you are asked to form the characters into the shape of U. For example, helloworld can be printed as:

h d
e l
l r
lowo
That is, the characters must be printed in the original order, starting top-down from the left vertical line with n
​1
​​ characters, then left to right along the bottom line with n
​2
​​ characters, and finally bottom-up along the vertical line with n
​3
​​ characters. And more, we would like U to be as squared as possible – that is, it must be satisfied that n​1=n​3​​ =max { k | k≤n2​​ for all 3≤n​2​​ ≤N } with n​1+n​2+n​3 −2=N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!
Sample Output:

h !
e d
l l
lowor


//我这里的n1比题目中的n1小了1
//即以下代码中n1 + n2 + n3 = N

#include <cstdio>
#include <cstring>
#include <cmath>

int main()
{
	char str[100] = { 0 };
	scanf("%s", str);
	int len = strlen(str);
	int n1 = len / 3;//一般情况
	if(len%3 == 0) n1 -= 1;//为了满足n1 = n3 = max { k | k≤n2 for all 3≤n≤N } 
	int n2 = len - 2 * n1;
	for (int i = 0; i < n1; i++)
	{
		printf("%c", str[i]);//输出左半边
		for (int j = 1; j < n2 - 1; j++) printf(" ");
		printf("%c\n", str[len - i - 1]);//输出右半边
	}
	for (int i = n1; i < len - n1; i++) printf("%c", str[i]);//输出最下一行
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值