1031. Hello World for U (20)【字符串处理】——PAT (Advanced Level) Practise

题目信息

1031. Hello World for U (20)

时间限制400 ms
内存限制65536 kB
代码长度限制16000 B

Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, “helloworld” can be printed as:

h  d
e  l
l  r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1 characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n3 characters. And more, we would like U to be as squared as possible – that is, it must be satisfied that n1 = n3 = max { k| k <= n2 for all 3 <= n2 <= N } with n1 + n2 + n3 - 2 = N.
Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:
helloworld!
Sample Output:

h   !
e   d
l   l
lowor

解题思路

字符串操作

AC代码

#include <stdio.h>
#include <string.h>
int main()
{
    char s[100];
    scanf("%s", s);
    int len = strlen(s);
    int tl = (len + 2) / 3 - 1;
    int sp = len - tl * 2 - 2;
    int i = 0;
    for (i = 0; i < tl; ++i){
        putchar(s[i]);
        int t = sp;
        while (t-- > 0) putchar(' ');
        putchar(s[len - 1 - i]);
        putchar('\n');
    }
    for (;i < len - tl; ++i) putchar(s[i]);
    putchar('\n');
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值