The kth great number - set

Xiao Ming and Xiao Bao are playing a simple Numbers game. In a round Xiao Ming can choose to write down a number, or ask Xiao Bao what the kth great number is. Because the number written by Xiao Ming is too much, Xiao Bao is feeling giddy. Now, try to help Xiao Bao.
InputThere are several test cases. For each test case, the first line of input contains two positive integer n, k. Then n lines follow. If Xiao Ming choose to write down a number, there will be an " I" followed by a number that Xiao Ming will write down. If Xiao Ming choose to ask Xiao Bao, there will be a "Q", then you need to output the kth great number. 
OutputThe output consists of one integer representing the largest number of islands that all lie on one line. 
Sample Input
8 3
I 1
I 2
I 3
Q
I 5
Q
I 4
Q
Sample Output
1
2
3


        
  
Hint
Xiao  Ming  won't  ask  Xiao  Bao  the  kth  great  number  when  the  number  of  the  written number is smaller than k. (1=<k<=n<=1000000).
        
 

#include<iostream>
#include<cstdio>
#include<set>

using namespace std;

int main(){
    int n,k,d;
    char ch;
    while(cin>>n>>k){
        multiset<int> s;
        while(n--){
            cin>>ch;
            if(ch=='I'){
                cin>>d;
                s.insert(d);
                if(s.size()>k)s.erase(s.begin());
            }
            else cout<<*s.begin()<<endl;
        }
    }
}

这里用到了multiset

1.需要用头文件#include<set>

2.不同于集合set的是允许重复的数存在

3.set中元素自动从小到大排列

4.s.begin()与s.end()都是指针,指向地址,所以最后输出的时候加*

5.我刚开始做的时候用的数组,而且还保存了输入的每一个数(太蠢了)结果超时了,题上只问你,第k大的数是多少,所以只保留k个元素,当s.size()>k是就s.erase(s.begin())把最小的数去掉。

set讲解:

http://blog.sina.com.cn/s/blog_aa90eb1e0101edew.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值