A Simple Problem with Integers(区间更新+区间查询)

You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of Aa, Aa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of Aa, Aa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input
10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4
Sample Output
4
55
9
15
Hint
The sums may exceed the range of 32-bit integers.

思路:线段树

#include<stdio.h>
#include<string.h>
using namespace std;
typedef long long ll;
const int N = 100005;
struct node{
	int l,r;
	ll val,lazy;//lazy 为懒惰标记, 
	int length; //区间长度 
}tree[N*4];
int n,m;
ll arr[N];
void pushUp(int root){
	tree[root].val=tree[root*2].val+tree[root*2+1].val;
}
void mark_down(int root){ //懒惰标记下移 
     if(tree[root].lazy){
     	tree[root*2].val+=tree[root].lazy*tree[root*2].length;
		tree[root*2+1].val+=tree[root].lazy*tree[root*2+1].length;
		tree[root*2].lazy+=tree[root].lazy;
		tree[root*2+1].lazy+=tree[root].lazy;
		tree[root].lazy=0;
	 }
}
void build(int root,ll arr[],int left,int right){
	tree[root].l=left;
	tree[root].r=right;
	tree[root].lazy=0;
	tree[root].length=right-left+1;
	if(left==right){
		tree[root].val=arr[left];
		return;
	}
	int mid=(left+right)/2;
	build(root*2,arr,left,mid);
	build(root*2+1,arr,mid+1,right);
	pushUp(root);
}
void update(int root,int left,int right,int data){ //区间更新 
	if(tree[root].l==left&&tree[root].r==right){
		tree[root].val+=data*tree[root].length;
		tree[root].lazy+=data;
		return;
	}
	mark_down(root);
	if(left>tree[root].r||right<tree[root].l) return;
	int mid=(tree[root].l+tree[root].r)/2;
	if(right<=mid) update(root*2,left,right,data);
	else if(left>mid) update(root*2+1,left,right,data);
	else{
		update(root*2,left,mid,data);
		update(root*2+1,mid+1,right,data);
	}
	pushUp(root);
}
ll query(int root,int left,int right){ //区间查询 
   if(tree[root].l==left&&tree[root].r==right) return tree[root].val;
   mark_down(root);
   pushUp(root);
   if(right<tree[root].l||left>tree[root].r) return 0;
   int mid=(tree[root].l+tree[root].r)/2;
   if(right<=mid) return query(root*2,left,right);
   else if(left>mid) return query(root*2+1,left,right);
   else{
   	 ll L=query(root*2,left,mid);
   	 ll R=query(root*2+1,mid+1,right);
   	 return L+R;
   } 
}
int main(){
	while(scanf("%d%d",&n,&m)!=EOF){
		memset(tree,0,sizeof(tree));
		for(int i=1;i<=n;i++)
		   scanf("%lld",&arr[i]);
		 build(1,arr,1,n); 
		while(m--){
			char op[5];
			int a,b;
			scanf("%s%d%d",op,&a,&b);
			if(op[0]=='C'){
				ll c;
				scanf("%lld",&c);
				update(1,a,b,c);
			}
			else printf("%lld\n",query(1,a,b));
		}
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值