Moo University - Financial Aid - poj2010 - 二分搜索+优先队列

Moo University - Financial Aid

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 11721 Accepted: 3463

Description

Bessie noted that although humans have many universities they can attend, cows have none. To remedy this problem, she and her fellow cows formed a new university called The University of Wisconsin-Farmside,"Moo U" for short. 

Not wishing to admit dumber-than-average cows, the founders created an incredibly precise admission exam called the Cow Scholastic Aptitude Test (CSAT) that yields scores in the range 1..2,000,000,000. 

Moo U is very expensive to attend; not all calves can afford it.In fact, most calves need some sort of financial aid (0 <= aid <=100,000). The government does not provide scholarships to calves,so all the money must come from the university's limited fund (whose total money is F, 0 <= F <= 2,000,000,000). 

Worse still, Moo U only has classrooms for an odd number N (1 <= N <= 19,999) of the C (N <= C <= 100,000) calves who have applied.Bessie wants to admit exactly N calves in order to maximize educational opportunity. She still wants the median CSAT score of the admitted calves to be as high as possible. 

Recall that the median of a set of integers whose size is odd is the middle value when they are sorted. For example, the median of the set {3, 8, 9, 7, 5} is 7, as there are exactly two values above 7 and exactly two values below it. 

Given the score and required financial aid for each calf that applies, the total number of calves to accept, and the total amount of money Bessie has for financial aid, determine the maximum median score Bessie can obtain by carefully admitting an optimal set of calves. 
 

Input

* Line 1: Three space-separated integers N, C, and F 

* Lines 2..C+1: Two space-separated integers per line. The first is the calf's CSAT score; the second integer is the required amount of financial aid the calf needs 

Output

* Line 1: A single integer, the maximum median score that Bessie can achieve. If there is insufficient money to admit N calves,output -1. 

Sample Input

3 5 70
30 25
50 21
20 20
5 18
35 30

Sample Output

35

Hint

Sample output:If Bessie accepts the calves with CSAT scores of 5, 35, and 50, the median is 35. The total financial aid required is 18 + 30 + 21 = 69 <= 70. 

Source

USACO 2004 March Green

思路:

终于把这个题过了,hiahiahia~,在第二章碰见的时候还不会写,一直超时,学了3.1二分以后就有思路了,因为书上给的例子大多是二分所求的值,所以对于首刷这类题没经验的我,一开始想到的就是(0~2.000.000.000)枚举中位数,样例过了,但就是WA,然后看了网上说的是二分数组下标,把数组按分数从小到大,(0,c)枚举数组下标,每次枚举都判断是否成立,成立的话left=mid,反之right=mid。最后终于AC了~

代码如下:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstring>
#include<string>
#include<vector>
#include<queue>
using namespace std;
const int maxc=100005,INF=2000000000;
int n,c,f,q;
struct A{
	int score,aid;
}cow[maxc];
int g[maxc];
bool cmp(A a,A b){//按分数从小到大排序 
	return a.score<b.score;
}

bool C(int i){//用i位置上的score做为中位数行不行 
    int sum=f-cow[i].aid;
	priority_queue<int,vector<int>,greater<int> >low;
	priority_queue<int,vector<int>,greater<int> >high;
	for(int j=0;j<i;j++){
		low.push(cow[j].aid);
	}
	for(int j=i+1;j<c;j++){
		high.push(cow[j].aid);
	}
	for(int j=0;j<q;j++){
		int t1=low.top(),t2=high.top();
		low.pop();high.pop();
		sum-=(t1+t2);
		if(sum<0)break;
	}
	if(sum>=0)return true;
	else return false; 
}

int main(){
	scanf("%d%d%d",&n,&c,&f);
	for(int i=0;i<c;i++){
		scanf("%d%d",&cow[i].score,&cow[i].aid);
		g[i]=cow[i].score;
	}
	sort(cow,cow+c,cmp);
	sort(g,g+c);
	int left=0,right=c-1;
	q=n/2;
	while(right-left>1){//枚举最大的中位数的下标
		int mid=(left+right)/2;
		if(mid>=q&&(c-mid-1)>=q&&C(mid))left=mid;
		else right=mid; 
	}
	int ans;
	if(!left)ans=-1;
	else ans=cow[left].score;
	printf("%d\n",ans);
}

错误代码:

(有没有大佬路过给我说说为啥QwQ)

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstring>
#include<string>
#include<vector>
#include<queue>
using namespace std;
const int maxc=100005,INF=2000000000;
int n,c,f;
struct A{
	int score,aid;
}cow[maxc];
int g[maxc];
bool cmp(A a,A b){//按分数从小到大排序 
	return a.score<b.score;
}

bool C(int s){//要求平均分>=x 
    if(cow[c-1].score<s)return false;
    int q=n/2;
	for(int i=0;i<c;i++){
		if(cow[i].score>=s&&i>=q&&(c-i-1)>=q){
			int sum=f-cow[i].aid;
			priority_queue<int,vector<int>,greater<int> >low;
			priority_queue<int,vector<int>,greater<int> >high;
			for(int j=0;j<i;j++){
				low.push(cow[j].aid);
			}
			for(int j=i+1;j<c;j++){
				high.push(cow[j].aid);
			}
			for(int j=0;j<q;j++){
				int t1=low.top(),t2=high.top();
				low.pop();high.pop();
				sum-=(t1+t2);
				if(sum<0)break;
			}
			if(sum>=0)return true;
		}
	} 
	return false;
} 

int main(){
	scanf("%d%d%d",&n,&c,&f);
	for(int i=0;i<c;i++){
		scanf("%d%d",&cow[i].score,&cow[i].aid);
		g[i]=cow[i].score;
	}
	sort(cow,cow+c,cmp);
	sort(g,g+c);
	int left=0,right=INF;
	while(right-left>1){//枚举最大的中位数,中位数>=mid 
		int mid=(left+right)/2;
		if(C(mid))left=mid;
		else right=mid; 
	}
	int ans;
	if(!left)ans=-1;
	else ans=*lower_bound(g,g+c,left);
	printf("%d\n",ans);
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值