北大oj1001——Exponentiation(高精度计算)

Description

Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems.

This problem requires that you write a program to compute the exact value of Rn where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.

Input

The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.

Output

The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer.

Sample Input

95.123 12

0.4321 20

5.1234 15

6.7592 9

98.999 10

1.0100 12

Sample Output

548815620517731830194541.899025343415715973535967221869852721

.00000005148554641076956121994511276767154838481760200726351203835429763013462401

43992025569.928573701266488041146654993318703707511666295476720493953024

29448126.764121021618164430206909037173276672

90429072743629540498.107596019456651774561044010001

1.126825030131969720661201

主要使用的就是高精度计算,其次就是注意一些边界问题:

过程写的稍微有点啰嗦,不过这题比较简单,就酱啦。

//高精度运算
#include <iostream>
#include <algorithm>
using namespace std;

int totalArray[200];

int main()
{
    char s[6];
    int n;
    while(cin >> s >> n){
        int decimal = 0;    //小数总位数
        int num = 0;        //整数值
        //第一步,先确定小数位数,把小数转化为整数计算
        
        for (int i = 0; i < strlen(s); i++) {
            if (s[i] == '.') {
                decimal = (strlen(s) - 1 - i) * n;
            }
            else {
                num = num * 10 + s[i] - '0';
            }
        }

        if (n == 0 || num == 0) {
            cout << 0;
            cout << '\n';
            continue;
        }

        for (int i = 1; i < 200; i++) {
            totalArray[i] = 0;
        }
        totalArray[0] = 1;      //初始化,用来首次计算
        int index = 1;          //标记当前计算到的位置
        for (int i = 0; i < n; i++) {
             //开始倒算
            int len = 0;
            int more = 0;   //进位
            for (len = 0; len < index; len++) {
                int cur = totalArray[len] * num + more;
                totalArray[len] = cur % 10;
                more = cur / 10;
            }
            while (more > 0) {
                totalArray[len++] = more % 10;
                more /= 10;
            }
            index = len;
        }

        //开始输出结果
        //小数位比总算的位数还要大
        if (decimal >= index) {
            cout << '.';
            for (int i = 0; i < index - decimal; i++) {
                cout << 0;
            }
            int calcZero = 0;
            while(totalArray[calcZero] == 0 && calcZero < decimal)
            {
                calcZero++;
            }
            for (int i = decimal - 1; i > calcZero - 1; i--) {
                cout << totalArray[i];
            }
        }
        else { //大于1的计算
            int calcBigZero = index - 1;
            while (totalArray[calcBigZero] == 0 && calcBigZero >= decimal) {
                calcBigZero--;
            }
            for (int i = calcBigZero; i >= decimal; i--) {
                cout << totalArray[i];
            }
            int calcLittleZero = 0;
            while (totalArray[calcLittleZero] == 0 && calcLittleZero < decimal)
            {
                calcLittleZero++;
            }
            if (calcBigZero == calcLittleZero) {
                cout << 0;
            }
            if (calcLittleZero != decimal) {
                cout << '.';
                for (int i = decimal - 1; i > calcLittleZero - 1; i--) {
                    cout << totalArray[i];
                }
            }
        }
        cout << '\n';
    }
    return 0;
}
  • 0
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

椰子糖莫莫

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值