[SDUT](3343)数据结构实验之二叉树四:(先序中序)还原二叉树

Problem Description

给定一棵二叉树的先序遍历序列和中序遍历序列,要求计算该二叉树的高度。

Input

输入数据有多组,每组数据第一行输入1个正整数N(1 <= N <= 50)为树中结点总数,随后2行先后给出先序和中序遍历序列,均是长度为N的不包含重复英文字母(区分大小写)的字符串。

Output

输出一个整数,即该二叉树的高度。

Example Input

9
ABDFGHIEC
FDHGIBEAC

Example Output

5

AC代码:

#include<bits/stdc++.h>
using namespace std;
typedef struct Node
{
    char data;
    struct Node *lchild,*rchild;
}node;
char tree1[55];
char tree2[55];
int first;
node *creat()
{
    node *root;
    root = (node *)malloc(sizeof(node));
    root->lchild = NULL;
    root->rchild = NULL;
    return root;
}
node *build(int low,int high)//二叉树的构建(由先序遍历和中序遍历确定)
{
    int flag;
    if(low>high)
        return NULL;
    else
    {
        for(int i=low;i<=high;i++)
        {
            if(tree1[first] == tree2[i])
            {
                flag = i;
                break;
            }
        }
    }
    first++;
    node *root = creat();
    root->data = tree2[flag];
    root->lchild = build(low,flag-1);
    root->rchild = build(flag+1,high);
    return root;
}
int height(node *root)
{
    int left;
    int right;
    if(root == NULL)
        return 0;
    else
    {
        left = height(root->lchild);
        right = height(root->rchild);
        return (left>right)?(left+1):(right+1);
    }
}
int main()
{
    int n;
    ios_base::sync_with_stdio(false);
    cin.tie(NULL),cout.tie(NULL);
    while(cin>>n)
    {
        first = 0;
        cin>>tree1;
        cin>>tree2;
        node *root = build(0,n-1);
        cout<<height(root)<<endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值