poj 2262 Goldbach's Conjecture 【素数筛法】

Goldbach's Conjecture
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 46613 Accepted: 17762

Description

In 1742, Christian Goldbach, a German amateur mathematician, sent a letter to Leonhard Euler in which he made the following conjecture: 
Every even number greater than 4 can be 
written as the sum of two odd prime numbers.

For example: 
8 = 3 + 5. Both 3 and 5 are odd prime numbers. 
20 = 3 + 17 = 7 + 13. 
42 = 5 + 37 = 11 + 31 = 13 + 29 = 19 + 23.

Today it is still unproven whether the conjecture is right. (Oh wait, I have the proof of course, but it is too long to write it on the margin of this page.) 
Anyway, your task is now to verify Goldbach's conjecture for all even numbers less than a million. 

Input

The input will contain one or more test cases. 
Each test case consists of one even integer n with 6 <= n < 1000000. 
Input will be terminated by a value of 0 for n.

Output

For each test case, print one line of the form n = a + b, where a and b are odd primes. Numbers and operators should be separated by exactly one blank like in the sample output below. If there is more than one pair of odd primes adding up to n, choose the pair where the difference b - a is maximized. If there is no such pair, print a line saying "Goldbach's conjecture is wrong."

Sample Input

8
20
42
0

Sample Output

8 = 3 + 5
20 = 3 + 17
42 = 5 + 37


题意:


ac 400多ms  c++

#include<iostream>
#include<string.h>
#include<string>
using namespace std;
bool u[1111111];  //筛子 筛出素数为1
int su[1111111]={0},num;  //素数表为 su  长度为num
int n;
void prepare()
{
	memset(u,true,sizeof(u));
	for(int i=2;i<=1000000;i++){
		if(u[i]) su[++num]=i;
		for(int j=1;j<=num;j++){
			if(i*su[j]>1000000) break;  
			u[i*su[j]]=false; //将i与当前素数的乘积从素数中筛去
			if(i%su[j]==0) break;
		}
	}
}
int main()
{
	ios::sync_with_stdio(false);
	prepare();  //离线处理
	while(cin>>n&&n){
		int j;
		bool ok=false;
		for(j=2;j<=num;j++)
		{
			if(2*su[j]>n) break;
			if(u[n-su[j]]){  //贪心从小搜到大
				ok=true;  //是否找到
				break;  //找到以j为小素数,n-su[j]为大素数
			}
		}
		if(!ok) cout<<"Goldbach's conjecture is wrong."<<endl;  //未找到
		else
			cout<<n<<" = "<<su[j]<<" + "<<n-su[j]<<endl;  //找到
	}
	return 0;
}


这  这   变量的定义域也大有讲究,迷了我十几分钟,真菜,该打脸。



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值