2010 ACM/ICPC 福州赛区 Problem H(贪心)

Problem 2007 Selecting courses

Accept: 68    Submit: 275
Time Limit: 1000 mSec    Memory Limit : 32768 KB

Problem Description

A new Semester is coming and students are troubling for selecting courses. Students select their course on the web course system. There are n courses, the ith course is available during the time interval (Ai,Bi). That means, if you want to select the ith course, you must select it after time Ai and before time Bi. Ai and Bi are all in minutes. A student can only try to select a course every 5 minutes, but he can start trying at any time, and try as many times as he wants. For example, if you start trying to select courses at 5 minutes 21 seconds, then you can make other tries at 10 minutes 21 seconds, 15 minutes 21 seconds,20 minutes 21 seconds… and so on. A student can’t select more than one course at the same time. It may happen that no course is available when a student is making a try to select a course

You are to find the maximum number of courses that a student can select.

Input

There are no more than 100 test cases.

The first line of each test case contains an integer N. N is the number of courses (0<N<=300)

Then N lines follows. Each line contains two integers Ai and Bi (0<=Ai<Bi<=1000), meaning that the ith course is available during the time interval (Ai,Bi).

The input ends by N = 0.

Output

For each test case output a line containing an integer indicating the maximum number of courses that a student can select.

Sample Input

2
1 10
4 5
0

Sample Output

2

Source

The 35th ACM/ICPC Asia Regional Fuzhou Site 

思路:由于每门课可选时间段的两个端点都为整数,因此开始选课的时间在一个非整数的时间较好;

系统5分钟刷新一次,由此我们有5种开始选课时间需要枚举,即区间(0,1)(1,2)(2,3)(3,4)(4,5)这五个区间中的任意时刻;

贪心策略:在当前所有可选的课程中,选择最早结束的一门课(区间调度问题的核心思想点击打开链接);


代码:

#include <bits/stdc++.h>
using namespace std;

const int maxn=310;
pair<int ,int> s[maxn];
bool visit[maxn];
int Max=0,ans,flag,n;

int main()
{
          while(scanf("%d",&n)&&n)
          {
                   for(int i=0;i<n;i++)
                           scanf("%d%d",&s[i].first,&s[i].second);
                   for(int i=0;i<5;i++)//枚举五个起始区间(i,i+1)
                   {
                            memset(visit,0,sizeof(visit));
                            ans=0;
                            for(int j=i;j<=1000;j+=5)//以j作为选课时间
                            {
                                        flag=-1;//记录所选编号
                                        for(int k=0;k<n;k++)
                                                    if(!visit[k]&&s[k].first<=j&&s[k].second>j)//所有可选工作
                                                                 if(flag==-1||s[flag].second>s[k].second)//选择最早结束的
                                                                               flag=k;
                                         if(flag!=-1)
                                         {
                                                     ans++;
                                                     visit[flag]=1;
                                         }
                              }
                              Max=max(Max,ans);
                 }
                 printf("%d\n",Max);
         }
         return 0;
}


     

                                                  

   




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值