POJ 3169 Layout(差分约束系统)

Layout
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 12069 Accepted: 5804

Description

Like everyone else, cows like to stand close to their friends when queuing for feed. FJ has N (2 <= N <= 1,000) cows numbered 1..N standing along a straight line waiting for feed. The cows are standing in the same order as they are numbered, and since they can be rather pushy, it is possible that two or more cows can line up at exactly the same location (that is, if we think of each cow as being located at some coordinate on a number line, then it is possible for two or more cows to share the same coordinate). 

Some cows like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of ML (1 <= ML <= 10,000) constraints describes which cows like each other and the maximum distance by which they may be separated; a subsequent list of MD constraints (1 <= MD <= 10,000) tells which cows dislike each other and the minimum distance by which they must be separated. 

Your job is to compute, if possible, the maximum possible distance between cow 1 and cow N that satisfies the distance constraints.

Input

Line 1: Three space-separated integers: N, ML, and MD. 

Lines 2..ML+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at most D (1 <= D <= 1,000,000) apart. 

Lines ML+2..ML+MD+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at least D (1 <= D <= 1,000,000) apart.

Output

Line 1: A single integer. If no line-up is possible, output -1. If cows 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between cows 1 and N.

Sample Input

4 2 1
1 3 10
2 4 20
2 3 3

Sample Output

27

Hint

Explanation of the sample: 

There are 4 cows. Cows #1 and #3 must be no more than 10 units apart, cows #2 and #4 must be no more than 20 units apart, and cows #2 and #3 dislike each other and must be no fewer than 3 units apart. 

The best layout, in terms of coordinates on a number line, is to put cow #1 at 0, cow #2 at 7, cow #3 at 10, and cow #4 at 27.

Source


题意:n头牛编号为1到n,按照编号的顺序排成一列,每两头牛的之间的距离 >= 0。这些牛的距离存在着一些约束关系:1.有ml组(u, v, w)的约束关系,表示牛[u]和牛[v]之间的距离必须 <= w。2.有md组(u, v, w)的约束关系,表示牛[u]和牛[v]之间的距离必须 >= w。问如果这n头无法排成队伍,则输出-1,如果牛[1]和牛[n]的距离可以无限远,则输出-2,否则则输出牛[1]和牛[n]之间的最大距离。

差分约束+SPFA,不过要注意题目的隐藏边,每两头牛之间的距离大于等于0。


代码:

#include <iostream>  
#include <stack>  
#include <algorithm>  
#include <string.h>  
using namespace std;  
  
const int MAXN = 1005;  
const int MAXE = 21005;  
  
typedef struct Edge  
{  
    int v, w;  
    int next;  
}Edge;  
  
Edge edge[MAXE];  
int dist[MAXN], head[MAXN]; 
int Count[MAXN];//记录顶点进栈次数 
bool used[MAXN];  
int cnt=0, n, m;  
  
void add_edge(int u, int v, int w)  
{  
    edge[cnt].v = v;  
    edge[cnt].w = w;  
    edge[cnt].next = head[u];  
    head[u] = cnt++;  
}  
  
bool spfa()  
{  
    int sta[MAXN];  
    memset(used, false, sizeof(used));  
    memset(dist, 0x3f, sizeof(dist));  
    int top=0;  
    sta[++top] = 1;//进栈   
    dist[1] = 0;  
    used[1] = true;//标记   
    while (top)  
    {  
        int u = sta[top--];//出栈   
        used[u] = false;//去除标记   
        for (int i=head[u]; i!=-1; i=edge[i].next)  
        {  
            int v = edge[i].v;  
            int w = edge[i].w;  
            if (dist[v]>dist[u]+w)  
            {  
                dist[v] = dist[u] + w;  
                if (!used[v])  
                {  
                    used[v] = true;  
                    sta[++top] = v;
					Count[v]++;
					if(Count[v]>n)//进栈超过n次,存在负环 
					    return true;  
                }  
            }  
        }  
    } 
	return false; 
}  

int main()
{
	memset(head,-1,sizeof(head));
	memset(Count,0,sizeof(Count));
    int ml, md;
    scanf("%d%d%d", &n, &ml, &md);
    int u, v, w;
    while(ml --)
	{
        scanf("%d%d%d", &u, &v, &w);
        add_edge(u, v, w);
    }
    while(md --)
	{
        scanf("%d%d%d", &v, &u, &w);
        add_edge(u, v, -w);
    }
    for(int i = 1; i < n; i ++)//隐藏边
        add_edge(i + 1, i, 0);
        
    if(spfa())   printf("-1\n"); // 有负环存在,方程组无解。
    else if(dist[n] == 0x3f3f3f3f)   printf("-2\n"); // 距离为inf。
    else   printf("%d\n", dist[n]); // 有解且距离在一个范围内。
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值