poj 1026:Cipher

1026:Cipher

总时间限制: 
1000ms 
内存限制: 
65536kB
描述
Bob and Alice started to use a brand-new encoding scheme. Surprisingly it is not a Public Key Cryptosystem, but their encoding and decoding is based on secret keys. They chose the secret key at their last meeting in Philadelphia on February 16th, 1996. They chose as a secret key a sequence of n distinct integers, a1 ; . . .; an, greater than zero and less or equal to n. The encoding is based on the following principle. The message is written down below the key, so that characters in the message and numbers in the key are correspondingly aligned. Character in the message at the position i is written in the encoded message at the position ai, where ai is the corresponding number in the key. And then the encoded message is encoded in the same way. This process is repeated k times. After kth encoding they exchange their message.

The length of the message is always less or equal than n. If the message is shorter than n, then spaces are added to the end of the message to get the message with the length n.

Help Alice and Bob and write program which reads the key and then a sequence of pairs consisting of k and message to be encoded k times and produces a list of encoded messages. 
输入
The input file consists of several blocks. Each block has a number 0 < n <= 200 in the first line. The next line contains a sequence of n numbers pairwise distinct and each greater than zero and less or equal than n. Next lines contain integer number k and one message of ascii characters separated by one space. The lines are ended with eol, this eol does not belong to the message. The block ends with the separate line with the number 0. After the last block there is in separate line the number 0.
输出
Output is divided into blocks corresponding to the input blocks. Each block contains the encoded input messages in the same order as in input file. Each encoded message in the output file has the lenght n. After each block there is one empty line.
样例输入
10
4 5 3 7 2 8 1 6 10 9
1 Hello Bob
1995 CERC
0
0
样例输出
BolHeol  b
C RCE

来源
Central Europe 1995
相当于用一个置换作用,重复多次,把字符串打乱.求出每个数所在的轮换的大小,用k取模之后便知道最少作用多少次,求出变换之后的位置即可.
  • #include<iostream>
    #include<cmath>
    #include<cstring>
    #include<algorithm>
    #include<iomanip>
    #include<queue>
    #include<stack>
    #include<vector>
    #include<set>
    #include<map>
    using namespace std;
    int a[205];
    bool vis[205];
    int num[205];
    int Map[205];
    char s[205];
    int main()
    {
    	int n,k;
    	while(cin>>n&&n) 
    	{
    		for(int i=1;i<=n;++i)
    		{
    			cin>>a[i];
    		}
    		memset(vis,0,sizeof(vis));
    		for(int i=1;i<=n;++i)
    		{
    			if(vis[i])continue;
    			vis[i]=true;
    			int tmp=1;
    			for(int j=a[i];j!=i;j=a[j])
    			{
    				tmp++;
    				vis[j]=true;
    			} 
    			num[i]=tmp;
    			for(int j=a[i];j!=i;j=a[j])
    			{
    				num[j]=tmp;
    			}
    		}
    		while(cin>>k&&k)
    		{
    			getchar();
    			gets(s+1);
    			int len=strlen(s+1);
    			for(int i=len+1;i<=n;++i)
    			{
    				s[i]=' ';
    			}
    			s[n+1]='\0';
    			for(int i=1;i<=n;++i)
    			{
    				int j=i;
    				for(int t=0;t<(k%num[i]);++t)
    				{
    					j=a[j];
    				}
    				Map[j]=i;
    			}
    			for(int i=1;i<=n;++i)
    			{
    				cout<<s[Map[i]];
    			}
    			cout<<endl;
    		}
    		cout<<endl;
    	}
    	return 0;
    }
    


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值