[二分-二分最大化最小值]poj-2456

Aggressive cows
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 18456 Accepted: 8786

Description

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000). 

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

Input

* Line 1: Two space-separated integers: N and C 

* Lines 2..N+1: Line i+1 contains an integer stall location, xi

Output

* Line 1: One integer: the largest minimum distance

Sample Input

5 3
1
2
8
4
9

Sample Output

3

Hint

OUTPUT DETAILS: 

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3. 

Huge input data,scanf is recommended.

题意:

有n间牛舍和m头牛,第i号牛舍在xi的位置上,要求将牛放到牛舍中,且最大化任意两头牛的距离.

题解:

二分这个最大距离,

对于小的mid来说能放下的牛一定最多,于是在能放下n头牛的基础下不断增加left,最后的最优解为right

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<vector>
#include<algorithm>
using namespace std;
const int maxn = 1e5+10;
const int inf = 1e9+10;
vector<int> arr;
int n,c;
/*bool check(int mid) {
    int cnt = 1;
    vector<int>::iterator it = arr.begin();
    while(it != arr.end()) {
        it = lower_bound(arr.begin(),arr.end(),mid+*it);
        if(it != arr.end()) cnt++;
    }
    return cnt >= c;
}*/
bool check(int mid) {
    int cnt = 1,i = 1,it = 0;
    while(i < n) {
        if(arr[i] < arr[it] + mid) i++;
        else it = i,cnt++,i++;
    }
    return cnt >= c;
}
int main()
{
    while(~scanf("%d%d",&n,&c)) {
        for(int i=0;i<n;i++){
            int x;scanf("%d",&x);
            arr.push_back(x);
        }
        sort(arr.begin(),arr.end());
        int right = inf,left = 0;
        while(left <= right) {
            int mid = (right + left) / 2;
            if(check(mid)) left = mid + 1;
            else right = mid - 1;
        }
        printf("%d\n",right);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值