PAT-1023 Have Fun with Numbers (20 分)

1023 Have Fun with Numbers (20 分)

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.

Sample Input:

1234567899

Sample Output:

Yes
2469135798

思路

该题先用一个大小为10的数组统计初始输入的那个数中1、2、3、4、5、6、7、8、9、0的个数。

然后模拟乘法,统计1、2、3、4、。。。的个数与第一次统计的进行比较。

 

乘法有进位,如果carry不为0时,这个数的长度就加一了,所以这种情况输出的时候要注意。

 

代码

#include<cstdio>
#include<algorithm>
#include<cstring>

using namespace std;

const int maxn = 20 + 5;
int a[maxn], b[10];
char s[maxn];

void show_verse(int len1) {
	for (int i = len1 - 1; i >= 0; i--) {
		printf("%d", a[i]);
	}
	printf("\n");
}

int main(){
	scanf("%s", s);
	memset(b, 0, sizeof(b));
	int len1 = strlen(s);
	
	for (int i = 0; i < len1; i++) {
		a[len1 - i - 1] = s[i] - '0';
	}
	int tem;
	int add = 0;
	for (int i = 0; i < len1; i++) {
		b[a[i]]++;
		tem = a[i]*2 + add;
		add = tem/10;
		a[i] = tem%10;
	}
	
	if (add != 0) {
		 a[len1] = add;
		 printf("No\n");
		 show_verse(len1+1);
	} else {
		for (int j = 0; j < len1; j++) {
			b[a[j]]--;
		}
		for (int i = 0; i < 10; i++) {
			if (b[i] != 0) {
				printf("No\n");
				show_verse(len1);
				return 0;
			}
		}
		printf("Yes\n");
		show_verse(len1);
	}
	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Honyelchak

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值